NativeEdge: Troubleshooting Stalled Upload of Reset Recovery Image in NativeEdge Orchestrator

Summary: This article helps to troubleshoot the reasons for the stalled or stopped responding upload during the reset or recovery image for the NativeEdge endpoint.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

While creating the reset or recovery image of the NativeEdge endpoint, the download progress bar is unavailable and does not progress for a long time.

Cause

Check the logs of the fru-cru pod like below:

# kubectl get pods -A | grep fru-cru
hzp               hzp-fru-cru-svc-5fc46f884-5qv9p                     2/2     Running     0             15d
# kubectl logs hzp-fru-cru-svc-5fc46f884-5qv9p | grep "\/usbimage\/ENDPOINT_TAG"
 
Note: Substitute ENDPOINT_TAG with the tag of the endpoint that you are trying to download the reset image for.


If you see messages like below in the output, this means something in your infrastructure is blocking the file download.

[2025-04-14T12:14:26.600Z] "GET /api/v2/usbimage/ENDPOINT_TAG/reset HTTP/1.1" 200 DC downstream_remote_disconnect - "-" 0 32280362 1022292 6931 "172.18.141.2,161.200.40.200" "Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:137.0) Gecko/20100101 Firefox/137.0" "dad3e8ec-9330-4015-ab09-45821fa89f74" "internal.dns.name.net" "161.200.40.236:8080" inbound|8080|| 127.0.0.6:33941 161.200.40.236:8080 161.200.40.200:36306 outbound_.80_._.hzp-fru-cru-svc.hzp.svc.cluster.local default

Resolution

Common reasons your infrastructure may block the image download include:

  • Browser timeout settings
  • Firewall
  • Anti-virus
  • Security extensions terminating large or slow downloads

Also, that may be intermediate proxies or Load Balancers: network devices between your browser and Istio ingress gateway of the NativeEdge, reverse proxy, or firewall timing out connections that exceed certain duration or size thresholds.

The most common options to try in such a scenario are:

  • Try another browser to download
  • Try another client machine to download
  • Check internal security rules with the administrator or the security administrator (file streaming limitations, internal files transferring: Firewall or anti-virus or browser extension)

If you are unable to fix the issue, contact Dell Support.
 

Affected Products

NativeEdge
Article Properties
Article Number: 000312858
Article Type: Solution
Last Modified: 14 May 2025
Version:  1
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