PowerProtect Data Manager: VMDK Failed to Restore to Original VM with Changed Size Error
Summary: PowerProtect Data Manager-VMDK failed to restore to original VM with changed size error.
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This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When restoring one VMDK to the original VM, it fails with error code ARV0007.
The relevant error message is:
Disk xxxx- "Hard disk x" has a changed size(in bytes) from xxx to xxx
Cause
The hard disk size was increased after the backup.
When PowerProtect Data Manager took the backup, the hard disk 1 size was still 40 GB. After the backup, the customer increased the size to 45 GB.
PowerProtect Data Manager does not support restoring this VMDK (Hard disk 1) back to the original VM since the Hard disk size changed.
When PowerProtect Data Manager took the backup, the hard disk 1 size was still 40 GB. After the backup, the customer increased the size to 45 GB.
PowerProtect Data Manager does not support restoring this VMDK (Hard disk 1) back to the original VM since the Hard disk size changed.
Resolution
If the VMDK is changed back to the original VM size, PowerProtect Data Manager allows the VMDK to be restored to the original VM. VMware only allows the VMDK size to be increased, not decreased.
The workaround is to restore the entire VM as a new VM or restore the VMDK to another VM.
Backups taken after the VMDK has been resized succeed as normal.
The workaround is to restore the entire VM as a new VM or restore the VMDK to another VM.
Backups taken after the VMDK has been resized succeed as normal.
Affected Products
PowerProtect Data Manager, PowerProtect SoftwareArticle Properties
Article Number: 000216495
Article Type: Solution
Last Modified: 11 Dec 2025
Version: 4
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