PowerStore: System Health Check has detected remnants of failed NDU commits
Summary: The System Check in the off-release health check package may detect the existence of an unfinished upgrade.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
System Health may fail the Unfinished Upgrade Check and display a failure message that an unfinished upgrade was identified. The message may be one of the following examples:
- Unfinished upgrade packages found. Software_Release-3.2.0.1-1860013-retail (Article#000213265)
- System upgrade status shows unfinished upgrade. (Article#000213265)
- Unfinished Upgrade Check node_a Failed nodea code commit is not complete nodeb code commit is not complete (Article#000213265)
- Running a System Check using PowerStore Manager (UI) with the Run System Check option
- Running the System Health Service Script (svc_health_check) using an SSH connection:
Cause
If an NDU was not successfully completed the system may be left in a status of "NDU In Progress" or with NDU commit failed.
Resolution
This issue must be resolved as soon as possible to prevent any possible service interruption.
Contact Dell Technical Support to resolve this issue. Reference this KB Article for expedited handling.
Contact Dell Technical Support to resolve this issue. Reference this KB Article for expedited handling.
Additional Information
For more information about System Health Checks, see Article 000198084 PowerStore: How to use the System Check feature or Article 000192601 PowerStore: How to Check the Health of the Cluster Before Software Upgrade Using Pre-Upgrade Health Check and System Check.
Affected Products
PowerStoreArticle Properties
Article Number: 000213265
Article Type: Solution
Last Modified: 03 Sep 2025
Version: 8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.