PowerStore: Pre-Upgrade Heath Check detects if reboot was using an incorrect boot entry option

Summary: This Pre-Upgrade Heath Check (PUHC) checks that the correct boot entry option is used on a PowerStore 500T.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The Pre-Upgrade Heath Check (PUHC) fails and the following message is displayed:
EFI current boot is not boot from expected entry. Please contact your service provider (efi_boot_check).

Or

EFI current boot is not boot from expected entry. Please contact your service provider (off_release_efi_boot_check).


Screenshot of the PUHC check: 
PUHC example

Cause

The wrong boot option may be configured following the change of internal operating system as part of PowerStore upgrade. This incorrect boot option results in the non-disruptive upgrade (NDU) failing on reboot of the 500T model node due to a reboot loop.
On PowerStore T models 1000T-9000T, this error is a false positive.

Resolution

For PowerStore 500T models ONLY:

  1. Reboot the node that failed. See the PowerStore 500T Installation and Service Guide section on Rebooting procedures for a PowerStore node.
  2. Re-run the PUHC after the node reboot.
  3. If the issue persists, contact Dell Technical Support


If this issue is detected on both Nodes, then:

  1. Confirm that the peer node is healthy. Use the System Check to confirm the health of the node.
  2. Reboot one node. See the500T Installation and Service Guide section on Rebooting procedures for a PowerStore node.
  3. Confirm that the node has rebooted successfully and is servicing Input and or Output.
  4. Wait for ten (10) minutes.
  5. Reboot the second node.
  6. Re-run the PUHC after the node reboot.
  7. If the issue persists, contact Dell Technical Support.


For 1000T to 9000T models:
  • Changes were made in the Health Check package PowerStore-health_check-3.6.1.0-2281324-retail.tgz.bin and later. The new package does not perform the off_release_efi_boot_check against the 1000T-9000T models, only for 500T models.
  • If the Pre Upgrade Health Check (PUHC) reports an error for off_release_efi_boot_check on a PowerStore model 1000T - 9000T:
    1. Install and run the health check package PowerStore-health_check-3.6.1.0-2281324-retail.tgz.bin or later.
    2. Run the upgrade or PUHC again.

Additional Information

Affected Products

PowerStore
Article Properties
Article Number: 000222187
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  11
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.