AppSync:アプリケーション検出フェーズ中にSQLサービス プランが「Unable to connect to database」エラーで失敗しました。

Summary: アプリケーション検出フェーズ中にSQLサービス プランが「Unable to connect to database」エラーで失敗しました。これは、SQLデータベースがオンライン状態になっていないか、ODBCドライバーが適切にインストールされていない場合に発生する可能性があります。詳細については、AppSyncホスト プラグインのログを確認してください。 ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

アプリケーション検出フェーズ中にサービス プランが「Unable to connect to database <Db name>」エラーで失敗しました。これは、SQLデータベースがオンライン状態になっていないか、ODBCドライバーが適切にインストールされていない場合に発生する可能性があります。
詳細については、AppSyncホスト プラグインのログを確認してください。

AppSyncイベント ログ:
 
Application discovery,7d2c438e-6ea7-4bb9-b515-0ce2594f9315,SQL_000141,<AppSync Server>,Unable to connect to database <Db name>. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.
 
AppSyncサーバー ログ:
 
07-02-2021 06:00:05.840 INFO [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [SQL_000141]: Unable to connect to database hostname.master. This can happen if either SQL database is not in online state or ODBC driver is not properly installed. Check the AppSync host plug-in log for more details.(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:05.840-0600NATIVETIME-2021-07-02 06:00:05.643-0600, HOST-hostname.a.b.corporate. com, PHASE-Application discovery, THREAD=17152, USER-null, CATEGORY-GENERIC, SESSIONID-null)
07-02-2021 06:00:05.841 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [org.jboss.as.ejb3.invocation] [ASServer] [] WFLYEJB0034: EJB Invocation failed on component SqlServiceBean for method public com.emc.archway.objectmodel.host.sql.SqlServerInstances com.emc.archway.service.sqlservice.SqlServiceBean.discoverDatabases(com.emc.archway.context.ExecutionContext,com.emc.archway.objectmodel.host.AgentHost,com.emc.archway.objectmodel.host.sql.SqlServerInstances) throws java.net.UnknownHostException,com.emc.archway.service.eventservice.exceptions.HostPluginDownException: javax.ejb.EJBException: java.lang.RuntimeException
07-02-2021 06:00:06.032 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: RuntimeException
07-02-2021 06:00:06.035 ERROR [Thread-28455 (HornetQ-client-global-threads-320952484)] [com.emc.archway.application.sqlserver.SqlServerCommandListenerBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> Exception Occurred: EJBException, Message: java.lang.RuntimeException
07-02-2021 06:00:07.272 INFO [Thread-28456 (HornetQ-client-global-threads-320952484)] [com.emc.archway.service.eventservice.EventServiceBean] [ASServer] [] d96dbf19-8962-4ef4-9e53-9d22e4af3e33->>> EVENT [MILE_000005]: Application discovery phase for hostname:Utility completed with errors(METADATA: TYPE-ERROR, TIME-2021-07-02 06:00:07.272-0600NATIVETIME-2021-07-02 06:00:07.272-0600, HOST-ASServer, PHASE-Application discovery, THREAD=Thread-28456 (HornetQ-client-global-threads-320952484), USER-null, CATEGORY-MILESTONE, SESSIONID-null)

Cause

AppSync for SQLに提供されたユーザーに必要な権限がないため、SQL DBの保護に失敗しました。
 


Resolution


DBのWindows認証を適切なユーザーにリセットすると、問題が解決します。

認証をリセットする手順:
 
1.AppSyncコンソールで、[Copy Management]を選択します。
2.[Copies]ドロップダウンから[Copies]を選択します。
3.[Select Application]ドロップダウンから、[Microsoft SQL Server]を選択してインスタンス ページを表示します。
4.データベースを選択し、[CONNECTION SETTINGS]をクリックします。
[SQL Server Connection settings]ダイアログが表示されます。
5.[Authentication]フィールドで、サイト要件ごとに次のいずれかを選択します。
● Windows認証
● SQL Server認証
6.次のフィールドの値を指定します。
● ユーザー名
● パスワード
7.[OK]をクリックします。

Affected Products

AppSync

Products

Data Protection, Data Backup & Protection Software
Article Properties
Article Number: 000189823
Article Type: Solution
Last Modified: 22 Oct 2024
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.