PowerStore: Service disruption may occur during host side UNMAP operations
Summary: Service disruption may occur due to a software issue during UNMAP operations from the host side.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
A PowerStore Node may experience software modules unexpected restart, and in some rare cases service disruption may occur if both nodes are affected.
Cause
A software issue has been identified where a large 1MB UNMAP operation followed by an overwrite to the same pages, may lead to a deadlock condition that triggers an internal software module restart.
Resolution
This issue is fixed in PowerStoreOS 3.5.0 and above.
Upgrade to the latest PowerStoreOS release (3.5.0 and above).
Upgrade to the latest PowerStoreOS release (3.5.0 and above).
Workaround
- If customer cannot upgrade, work with the customer to disable UNMAP operations from the hosts side
- For instructions on how to disable UNMAP, see the relevant OS administrator guide.
Affected Products
PowerStoreArticle Properties
Article Number: 000216201
Article Type: Solution
Last Modified: 26 Sept 2023
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.