Windows Server: Reported Serial Number Does Not Match Serial Number Printed on NVMe Drive
Summary: This article deals with the fact that the serial number reported in Windows Server Operating System does not match the serial number on the NVMe drive.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The serial number generated from the following PowerShell command does not match the serial number on the physical NVMe disk drive.
Windows Server 2016, 2019, 2022
Azure HCI 21H2, 22H2, 23H2
Affected PowerEdge Platforms:
All that supports NVMe drives.
Affected NVMe drive vendors:
All
Get-PhysicalDisk | Select SerialNumberAffected Microsoft Operating Systems:
Windows Server 2016, 2019, 2022
Azure HCI 21H2, 22H2, 23H2
Affected PowerEdge Platforms:
All that supports NVMe drives.
Affected NVMe drive vendors:
All
Cause
The above PowerShell command provides the Extended Unique Identifier (EUI) or the Namespace Globally Unique Identifier (NGUID) of NVMe disk drives. This is by design to ensure that the serial number field is unique in multiple namespace environments.
The serial number printed on the physical NVMe drive is in the AdapterSerialNumber field instead.
Resolution
Use the following PowerShell command to get the serial number of an NVMe disk drive.
Get-PhysicalDisk | Select AdapterSerialNumber
Affected Products
Dell EMC Cloud For Microsoft Azure Stack, Dell Hybrid Cloud System for Microsoft, Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022Article Properties
Article Number: 000218659
Article Type: Solution
Last Modified: 11 Mar 2026
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.