Windows Server: "A Remote Desktop Services deployment does not exist" message in Server Manager

Summary: This message may appear in Server Manager after Remote Desktop Services (RDS) role services are installed: "A Remote Desktop Services deployment does not exist in the server pool. To create a deployment, run the Add Roles and Features Wizard and select the Remote Desktop Services installation option." This article shows how to address this issue. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The following message appears in Server Manager when Remote Desktop Services is selected in the left pane:

A Remote Desktop Services deployment does not exist in the server pool.
To create a deployment, run the Add Roles and Features Wizard and select the Remote Desktop Services installation option.


As a result, the RDS graphical management interface cannot be used.

Cause

This message appears if RDS role services have been installed but no deployment has been created. Installing RDS role services manually is not recommended and does not result in a functional RDS deployment.

Resolution

To resolve the issue, complete the RDS deployment by using the Add Roles and Features wizard in Server Manager:
  1. From the Manage menu of Server Manger, select Add Roles and Features.
  2. Click Next on the opening screen of the wizard.
  3. Select Remote Desktop Services installation and click Next.
  4. Select either Standard deployment or Quick Start, depending on what is needed. Descriptions of both options are provided in the wizard.
  5. Follow the remaining steps of the wizard to complete the deployment. The proper selections depend on the environment, so they cannot be detailed here.
  6. A reboot may be necessary upon completion.
After the deployment has been completed, the message does not appear, and the RDS graphical interface is available in Server Manager.

Affected Products

Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Server 2022

Products

PowerEdge FC640, PowerEdge M640, PowerEdge M640 (for PE VRTX), PowerEdge MX740C, PowerEdge MX750c, PowerEdge MX760c, PowerEdge MX840C, PowerEdge R240, PowerEdge R250, PowerEdge R260, PowerEdge R340, PowerEdge R350, PowerEdge R360, PowerEdge R440 , PowerEdge R450, PowerEdge R540, PowerEdge R550, PowerEdge R640, PowerEdge R6415, PowerEdge R650, PowerEdge R650xs, PowerEdge R6515, PowerEdge R6525, PowerEdge R660, PowerEdge R660xs, PowerEdge R6615, PowerEdge R6625, PowerEdge R740, PowerEdge R740XD, PowerEdge R740XD2, PowerEdge R7415, PowerEdge R7425, PowerEdge R750, PowerEdge R750XA, PowerEdge R750xs, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R7615, PowerEdge R7625, PowerEdge R840, PowerEdge R860, PowerEdge R940, PowerEdge R940xa, PowerEdge R960, PowerEdge T140, PowerEdge T150, PowerEdge T160, PowerEdge T340, PowerEdge T350, PowerEdge T360, PowerEdge T440, PowerEdge T550, PowerEdge T560, PowerEdge T640 ...
Article Properties
Article Number: 000219084
Article Type: Solution
Last Modified: 07 Dec 2024
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.