PowerEdge: In Red Hat Enterprise Linux 9.3 performing nvidia-smi operations may report "no devices found."

Summary: After successful installation of NVIDIA GPU driver on Red Hat Enterprise Linux 9.3, performing nvidia-smi operations may report "no devices found."

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

After successful installation of NVIDIA GPU driver on Red Hat Enterprise Linux 9.3, performing nvidia-smi operations may report the error "no devices found."


Example:
nvidia-smi command
 

Cause

This occurs due to a driver error.

Resolution

This issue is resolved by installing NVIDIA driver 590.90.12 or later.
As a workaround for driver versions prior to 590.90.12 the NVIDIA driver can be installed with the open kernel option. 

 ./NVIDIA-Linux-x86_64-550.54.15.run -m=kernel-open

Affected Products

PowerEdge R750, PowerEdge R750XA, PowerEdge R7515, PowerEdge R7525, PowerEdge R760, PowerEdge R760XA, PowerEdge R7615, PowerEdge R7625, PowerEdge R770, PowerEdge R7715

Products

PowerEdge R7725, Red Hat Enterprise Linux Version 9
Article Properties
Article Number: 000224586
Article Type: Solution
Last Modified: 16 Apr 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.