PowerStore: Przesyłanie certyfikatu zarządzania HTTP podpisanego przez publiczną infrastrukturę PKI kończy się niepowodzeniem
Summary: Przesłanie podpisanego certyfikatu do PowerStore powoduje wystąpienie błędów: Nie udało się zaktualizować certyfikatu w magazynie poświadczeń. Sprawdź łańcuch certyfikatów (0xE09010010013), a certyfikat nie zawiera sieci SAN z adresem IP lub nazwą DNS (0xE090A0010009). ...
Symptoms
Failed to update certificate in credential store. Please verify your certificate chain (0xE09010010013).
Certificate does not contain SAN with IP address or DNS name (0xE090A0010009).
Ilustracja: błąd 0xE09010010013:
Ilustracja: błąd 0xE090A0010009:
Cause
Infrastruktura PKI zazwyczaj nie zezwala na adresy IP w sieci SAN dla certyfikatów publicznych. Publiczna infrastruktura kluczy publicznych zazwyczaj wystawia certyfikaty przeznaczone dla domen publicznych lub serwerów sieci Web.
Prywatna infrastruktura PKI zazwyczaj jest w stanie generować certyfikaty z siecią SAN, które zawierają dowolną liczbę adresów IPv4, adresów IPv6 i w pełni kwalifikowanych nazw domen (FQDN). Są one przeznaczone do świadczenia usług certyfikatów wewnętrznie w organizacji (intranet), a nie publicznie (Internet).
Resolution
Sprawdź, czy sieć SAN obejmuje adres IPv4 klastra, adres IPv6 i nazwę DNS urządzenia PowerStore.
Znajdź te informacje, korzystając z jednej z następujących metod:
- W narzędziu Microsoft Certificate Utility:
.crt lub .pem rozszerzenie. W wierszu polecenia lub programie PowerShell użyj polecenia certutil.exe:
certutil.exe -dump CertificateName.pem
- W powłoce systemu Linux korzystającej z OpenSSL:
openssl x509 -in certificateName.pem -text -noout
Jeśli w SAN nie ma wszystkich trzech wymaganych pól, skontaktuj się z dostawcą certyfikatu i poproś o podpisanie certyfikatu oraz upewnij się, że zawiera on wszystkie wymagane informacje. Jeśli nie mogą dostarczyć certyfikatu z tymi informacjami, należy wygenerować te certyfikaty za pośrednictwem prywatnego dostawcy PKI lub utworzyć lokalną infrastrukturę kluczy publicznych, która może podpisywać te certyfikaty.
Jeśli problemy nadal występują, a wszystkie informacje o certyfikatach wyglądają poprawnie, możesz skontaktować się z działem pomocy technicznej firmy Dell , aby uzyskać pomoc w rozwiązaniu problemu.