Dell NativeEdge: Download dal catalogo non riuscito con "Internal Server Error"

Summary: In NativeEdge Orchestrator 3.0.0.0, il download dal catalogo potrebbe non riuscire con "Internal Server Error"

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In NativeEdge Orchestrator 3.0.0.0 è stata introdotta una nuova funzionalità per scaricare direttamente blueprint e plug-in all'interno di NativeEdge Orchestrator in un ambiente senza airgap. È possibile che venga visualizzato un "errore interno del server" quando si tenta di scaricare plug-in di dimensioni maggiori. 

Errore interno del server durante il download di un plug-in di grandi dimensioni

Se si esaminano i registri di rete utilizzando lo strumento di sviluppo del browser, è possibile visualizzare "500 internal server error"

Errore 500 durante la visualizzazione dallo strumento di sviluppo del browser

Cause

Ciò si verifica quando il completamento di un download richiede più di 30 secondi. I registri nel back-end della fase generano l'errore riportato di seguito. 

message: 
"Requested URL: /plugins?title=Nativeedge%20Gcp%20Plugin&visibility=tenant&package_name=nativeedge-gcp-plugin&plugin_archive_url=https%3A%2F%2Fdownloads.dell.com%2FFOLDER12410532M%2F1%2Fnativeedge-gcp-plugin_1.10.10.0_J34CH.wgn ECONNABORTED timeout of 30000ms exceeded" 

Resolution

"500 internal server error" è un falso allarme. Nella maggior parte dei casi, il file del plug-in viene scaricato correttamente. 

Gli utenti possono aggiornare l'interfaccia di "Download from Catalog". Il plug-in scaricato viene visualizzato correttamente.

Come aggiornare l'interfaccia utente del catalogo

Se in ogni caso la soluzione alternativa di cui sopra non funziona, contattare il supporto Dell per un ulteriore risoluzione dei problemi. 

La correzione sarà disponibile nella versione futura di NativeEdge. 

Affected Products

NativeEdge Solutions, NativeEdge
Article Properties
Article Number: 000261316
Article Type: Solution
Last Modified: 22 Apr 2025
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.