Gaming Laptop Stops Responding at Dell Splash After Modifying the Power Levels
Summary: The following article provides information about a startup error on gaming laptops. The laptop stops responding after a restart because of modifying its power level setting using Throttlestop. ...
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Restart fails at Dell Splash after modifying the laptops power levels
Your gaming laptop does not proceed past the Dell Splash screen with the Dell Logo. This is after using the third-party application Throttlestop to modify the power levels (PL1 and PL2) value.
This affects the following products:
- Dell G15 5530 Laptop
- Dell G16 7630 Laptop
Cause
The third-party application is causing an issue with the wrong central processor unit (CPU) ratio.
Resolution
Note: This problem is related to the third-party application that is being used. This issue only occurs when using the application to change PL1 and PL2 and restart the laptop.
Press and hold down the power button on the laptop to force the laptop to shut down. Once the laptop has turned off, press the power button to turn it back on. The laptop completes startup and boots into the operating system. The issue does not recur.
Affected Products
Dell G15 5530, Dell G16 7630Article Properties
Article Number: 000350909
Article Type: Solution
Last Modified: 30 Jul 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.