IDPA ACM is Not Showing DPC Version, Error: Unable to Connect to Secure LDAP or AD

Summary: ACM is not showing data in the dashboard for DPC version due to Unable to connect to secure LDAP or AD error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Some data such as the System manager version is missing from ACM Dashboard. 

The ACM server.log file has the following error:

2019-08-30 10:53:25,045 ERROR [Thread-65867]-util.LDAPUtil: testConnection --> LDAP connection failed for Secure connection.javax.naming.CommunicationException: simple bind failed: xxx.xxx.xxx.xxx:636 [Root exception is javax.net.ssl.SSLHandshakeException: java.security.cert.CertificateException: No subject alternative names present]
2019-08-30 10:53:25,046 ERROR [Thread-65867]-dashboard.DataprotectionCentralDashboard: loadDataprotectionCentralDashboardResponse --> LDAP test connection failed:
com.emc.vcedpa.common.exception.ApplianceException: Unable to connect to secure LDAP/AD . Please verify whether the LDAP/AD Server provided is present as Alternate Name in LDAPS Certificate.
        at com.emc.vcedpa.common.util.LDAPUtil.testConnection(LDAPUtil.java:82)
        at com.emc.vcedpa.dashboard.DataprotectionCentralDashboard.loadDataprotectionCentralDashboardResponse(DataprotectionCentralDashboard.java:114)
        at com.emc.vcedpa.dashboard.DashboardResponse.loadDataprotectionCentralDashboardResponse(DashboardResponse.java:762)
        at com.emc.vcedpa.configure.DashboardInfoLoader$7.run(DashboardInfoLoader.java:156)
        at java.lang.Thread.run(Thread.java:748)

Cause

The ACM LDAP server is not configured correctly and that is causing the LDAP connection to fail.

Resolution

This is an issue with the ldapconfig.xml file on the ACM server. 

The ldapconfig.xml has the ACM IP address for the ldapHostName tag and not the ACM FQDN. The connection is trying to use the FQDN for the ACM, and it is causing the connection to the LDAP server to fail.

To resolve this issue, edit the following file with vi:

/usr/local/dataprotection/var/configmgr/server_data/config/ldapconfig.xml

Change the following tag:

Note: acmserver.domain.com is to be replaced with the FQDN of the actual ACM server.
 
<ldapHostName>999.99.99.999</ldapHostName>
To 
<ldapHostName>acmserver.domain.com</ldapHostName>

Reboot the ACM server. 

Contact Dell Support for more information.

Affected Products

PowerProtect Data Protection Software
Article Properties
Article Number: 000165559
Article Type: Solution
Last Modified: 25 Jun 2025
Version:  4
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