У звіті PowerProtect Data Manager немає даних

Summary: Звіт PowerProtect Data Manager раптово не показує жодних даних. Але ми повідомляємо, що двигун знаходиться в стані готовності.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Ця проблема з'явилася в PowerProtect Data Manager 19.14 і 19.15.
У звіті PowerProtect Data Manager немає даних.
У движку звітів ми можемо знайти наведену нижче помилку в /var/log/dellemc/agent/dpaagent.log (або в пакеті підтримки PowerProtect Data Manager:\var\log\reporting\logs\agent\dpaagent.log)
INFO     3345.3484     20240219:150901 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed.
WARN     3345.3484     20240219:150902 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 423
INFO     3345.3490     20240219:151406 com.emc.dpa.agent.mo - authenticate(): Certificates are being setup...
INFO     3345.3490     20240219:151511 com.emc.dpa.agent.mo - authenticate(): Using authType CERT
INFO     3345.3490     20240219:151511 com.emc.dpa.agent.mo - authenticate(): Attempting CREDS token, as the certificate based token generation is failed.
WARN     3345.3490     20240219:151511 com.emc.dpa.agent.mo - obtainAccessToken(): Failed to login to xxx.xxx.com with user admin: HTTP post status: 401

Cause

Можливо, термін дії білого списку IP-адрес для звітування минув (за замовчуванням встановлено 365 днів). Щоб підтвердити це, запустіть наведену нижче команду в клієнтському командному рядку PowerProtect Data Manager з користувачем адміністратора.

./ppcp rest --uri whitelist 

Якщо ви не бачите IP-адресу вузла звітування, у виводі наведеної вище команди це означає, що IP-адреса звітування наразі не знаходиться в білому списку. 
Нижче наведено приклад для «IP-адреса звітування наразі не внесена до білого списку», і ми повинні виконати кроки, описані в частині «Резолюція».

admin@ppdm:~/bin> ./ppcp rest --uri whitelist
===========================================================
PPCP  :  0.44
PPDM  :  19.14.0-20
Date  :  18 Dec 2023 10:41 CST
===========================================================
URL :  GET https://localhost:8443/api/v2/whitelist?page=1&pageSize=100 [localhost]
{
 "content": [],
 "page":
{   "number": 1,   "size": 0,   "totalElements": 0,   "totalPages": 0  }
}

 

Resolution

Крок 1: Виконайте команду нижче, замініть 10.xxx.xxx.xxx на ip-адресу вузла, що повідомляють клієнтів, і зберіть значення "expiresAt".

./ppcp rest https://10.xxx.xxx.xx:8443 --uri whitelist 
 

Крок 2:

Створіть файл під назвою payload.txt використання в клієнтах PowerProtect Data Manager за адресою /home/admin за допомогою наведеної нижче команди. 

vi payload.txt

Скопіюйте наведений нижче вміст у файл payload.txt; на цьому кроці update expiresЗначення минає через 3 роки з дати закінчення терміну дії та IP-адресу, оскільки клієнти повідомляють IP і зберігають файл.

{
            "expiresAt": "2027-02-27T12:57:10.389Z",
            "ip": "10.xxx.xxx.xxx",
            "roleId": "2bc98750-7675-0136-29e9-5bbd3ce729b0",
            "state": "APPROVED"
}


Крок 3: 

Запустіть нижче команду ppcp з ip-адресою вузла звітування. 

./ppcp rest --method POST https://10.xxx.xxx.xxx:8443 --uri whitelist --input payload.txt

 

Після виконання вищевказаних кроків ми повинні повторно згенерувати сертифікати на вузлі звітності. Щоб зробити те саме, виконайте наведені нижче дії:

Step 01: Make sure a single entry in crontab is present to generate certificates.

crontab -l

crontab -e

Step 02: remove old certificates from /opt/emc/dpa/agent/data/ppdm/rs directory.

rm -rf /opt/emc/dpa/agent/data/ppdm/rs

Step 03: DPA agent restart regenerate the certificates.

/opt/emc/dpa/services/bin/dpa.sh agent restart

Step 04: run below command

/opt/emc/dpa/services/bin/dpa.sh svc restart
 

 

Affected Products

PowerProtect Software
Article Properties
Article Number: 000222608
Article Type: Solution
Last Modified: 11 Dec 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.