PowerStore: Test Connection fails for SupportAssist in direct connect mode
Summary: The "TEST CONNECTION" button in the UI did not perform the connectivity check through proxy server when the proxy server is configured. It always checks the direct connection between PowerStore and the Dell backend server. If the PowerStore does not have direct access to the Dell backend server, the test fails when SupportAssist is working through proxy server. ...
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Symptoms
The SupportAssist with proxy server is configured, it works perfectly since logs get uploaded to cloudIQ and support can access the array remotely.
But the client may receive a following error when clicking the "TEST CONNECTION" button in the UI.
Verify for address: <Proxy server IP> and Port: <Proxy server port> failed. Reason is timedout
Cause
PowerStore Engineering confirmed a code issue where the TEST CONNECTION button in the UI ignores proxy server settings. If PowerStore is not able to reach out to the Dell backend server directly, the TEST CONNECTION check fails.
Resolution
The error can be safely ignored since it does not accurately reflect the state of SupportAssist.
The issue is fixed in PowerStoreOS 4.1.0.0.
Affected Products
PowerStoreArticle Properties
Article Number: 000223786
Article Type: Solution
Last Modified: 14 Apr 2025
Version: 3
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