PowerMax/PowerStore: SDNAS switch both Replication sides VDMs to maintenance mode on a production mode conflict

Summary: SDNAS set both replication VDMs (Source and DR) to maintenance mode. Data is not accessible when both VDMs are in Maintenance mode. This article describes how to recover from this condition. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The replication network connectivity is lost between the two systems, and then the customer performed "Unplanned Failover" from the UI. When the network is restored, both source and destination NAS servers are demoted to maintenance mode. This is by design, to prevent a conflict of dual production mode. 

Data is not accessible when both NAS servers are in Maintenance mode after replication network is restored. 

This issue affects both PowerMax and PowerStore.

Cause

The design of this feature is to bring both replication NAS servers (Source and DR) to maintenance mode to avoid conflict if both source and destination NAS servers are online in production mode.
"Unplanned Failover" should be used only when production NAS servers are dead/down and the system performs replication ping (ReplicationKeepAlive) to determine the source NAS servers status. If the source NAS server is active, then Unplanned Failover action is expected to fail. In our case, the customer simulated network failure, so the system allowed to bring DR to production mode that caused conflict after network connection was restored.  

Resolution

If this condition occurs, contact technical support referencing this KB article. A procedure will be performed to promote one of the NAS servers to production mode.
Note: Any writes to the resulting non-production mode NAS server while both NAS servers were in production mode will be lost.

Affected Products

PowerMax, PowerStore
Article Properties
Article Number: 000216718
Article Type: Solution
Last Modified: 14 Jun 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.