NetWorker: поиск и устранение неисправностей при монтировании носителя
Summary: Данная статья предназначена для помощи сторонникам и администраторам в определении причин проблем с чтением этикетки на ленточном или дисковом устройстве.
Symptoms
Если конфигурация библиотеки работала ранее и внезапно возникла проблема, рассмотрите возможные изменения, которые могут повлиять на чтение и монтирование меток:
- Изменение микропрограммы, драйвера или конфигурации робота, коммутатора или адаптера
- Добавление, замена или удаление накопителей, ленточных картриджей и других библиотечных компонентов
- Изменения или события любых компонентов шифрования (например, Decru или диспетчера ключей шифрования)
- Изменение версии программного обеспечения NetWorker или исправлений операционной системы
- Любое событие оборудования, такое как отключение питания или перезагрузка любого компонента в пути передачи данных.
- Расхождения между конфигурацией NetWorker и библиотекой (например, ленточные картриджи перемещены из-под контроля NetWorker)
Если маркировка или монтирование тома никогда не работали, убедитесь, что оборудование накопителя поддерживается в руководстве по совместимости оборудования NetWorker. Помните, что устройство может быть частично работоспособным; Обнаружение само по себе не гарантирует удобства использования или поддержки.
- Спорадические или систематические ошибки при попытке загрузить или смонтировать носитель
- Невозможно выполнить операции подключения или маркировки на определенном носителе
- Невозможность правильного использования съемных или дисковых носителей
- Статические носители, например дисковые устройства, не используются
- Тома, помеченные как «непомеченные» в объекте NSR Jukebox
- Тома, поле расположения которых помечено как NULL, несмотря на то, что они находятся в ленточной библиотеке
- Ошибки при монтировании, маркировке или сканировании носителей:
"Unexpected volume, wanted <volume_name>, got <different_volume_name>""Unexpected volid, wanted <mm_volid>, got <different_volid>"Duplicate volume name `<volume_name>'. Select a new name or remove the original volume.""scanner: Read -1 bytes""scanner: unexpected file number, wanted 2, got <different_number>""Opening the file '<disk_device_path>/volhdr' failed ([5004] nothing matched)""Waiting for <number> writable volume(s) to backup pool '<pool>' disk(s) or tape(s) on <storage_node>"Warning: Required volume <volume>'s status is off-line"
Операция монтирования NetWorker состоит из нескольких подопераций. Проверьте, на каком этапе произошел сбой монтирования:
- Выбор тома для операции NetWorker: Дополнительные сведения см. в разделе Поиск и устранение неисправностей выбора носителя в NetWorker .
- Загрузка выбранного тома в устройство NetWorker при необходимости: Дополнительные сведения см. в разделе Поиск и устранение неисправностей загрузки ленточной библиотеки в NetWorker .
- Попробуйте прочитать этикетку:
- Дисковое устройство -
volhdrФайл меток в корневом каталоге дискового устройства - Ленточное устройство (после загрузки) — перемотка назад и чтение Начало носителя Блок этикеток размером 32 КБ
- Ленточное устройство (после записи, Idle, уже загружено) - backspace один файл и чтение блока заголовка первой записи
- Дисковое устройство -
- Если по какой-либо причине не удастся прочитать метку, NetWorker предотвратит использование тома при любой повторной попытке:
- Диск или автономное ленточное устройство: размонтирование тома
- Ленточное устройство библиотеки: Выгрузите том, измените запись метки тома в объекте музыкального автомата nsr на *- (отсутствует в индексе носителя) и обновите поле местоположения базы данных мультимедиа на NULL
- Если чтение прошло успешно, сравните данные метки с ожидаемыми значениями (теми, которые содержатся в записи тома базы данных мультимедиа для выбранного тома):
- Имя тома
- Идентификатор тома
- Тип носителя
- Pool
- Если том проверен, он монтируется и считается доступным для операций чтения или записи в NetWorker:
- У объекта nsr device , выполняющего монтирование, обновлены поля тома (например, имя тома, идентификатор тома и т. д.).
- Если тома (и устройство) являются членами ленточной библиотеки, то в объекте nsr jukebox обновляются соответствующие поля (например , загруженные тома, загруженные слоты, загруженные штрихкоды).
- Если проверка завершается сбоем, возвращается «непредвиденная» ошибка:
- "Неожиданный объем, разыскивается
<volume_name>Получил<different_volume_name>» - «Неожиданно
volidХотел<mm_volid>Получил<different_volid> - Ленточное устройство библиотеки: Выгрузите том и измените запись метки тома в объекте музыкального автомата nsr на *- (не в индексе носителя)
- "Неожиданный объем, разыскивается
Монтажный носитель логически отделен от загрузочного материала. Нагрузка относится исключительно к логической (и потенциально физической) операции перемещения носителя в устройство. Растущие проблемы с проверкой носителя и его метки, а также с предоставлением их логической доступности для использования NetWorker. Библиотечные операции (nsrlcpd / NSR Jukebox) относятся к отображению дескрипторов drive element:host:device и физическому перемещению. Операции с накопителями (nsrmmd / NSR Device) обрабатывают все операции ввода-вывода устройства чтения и записи на ленту. Операции чтения и записи меток обрабатываются nsrsnmd. Таким образом, то, что кажется сбоями загрузки библиотеки, может быть сбоем монтирования диска, носителя или базы данных мультимедиа (или наоборот).
Примечание: Для дискового носителя, который уже смонтирован, новая сессия сохранения вызывает nsrmmd , чтобы проверить метку перед продолжением записи потока сохранения. Это может привести к периодическому размонтированию дисковых томов в случае сбоя проверки метки времени сохранения.
Обратите внимание, что эта простая сводка не включает представление логики выбора тома, узла или устройства.
Cause
Существует множество возможных причин сбоев считывания этикеток:
- Поврежденный том
- Метка перезаписана при перемотке
- Проблемы с заказом накопителей
- Несоответствия базы данных носителей
- Ошибки CDI
- Не удалось расшифровать зашифрованный том
- Неполадки сети или среды, приводящие к временному сбою чтения файлов volhdr
- Несовместимость библиотеки libDDBoost с версиями DD OS
Resolution
Для устранения неполадок при чтении и монтировании меток, рассмотрев последние известные изменения (если таковые имеются), перейдите к устранению неполадок, передав процесс его примитивным составляющим и протестировав их по отдельности.
В то время как полезные данные собирают NSRGet, большинство этих операций требуют ручного выполнения.
Библиотечная робототехника: коммуникации
- Убедитесь, что библиотека отвечает и готова к работе, прежде чем продолжить. Если нет:
Поиск и устранение неисправностей доступа к ленточной библиотеке в NetWorker
Поиск и устранение неисправностей при обнаружении ленточных библиотек в NetWorker
Поиск и устранение неисправностей загрузки ленточной библиотеки в NetWorker
Загрузка библиотеки без монтирования: логическая операция и порядок накопителей
После того, как мы убедились, что физические операции не содержат ошибок (по крайней мере, поверхностно), мы можем попытаться проследить проблему в NetWorker.
- Выгрузите все ленточные картриджи со всех устройств в библиотеке — во избежание путаницы очень важно убедиться, что смонтирован только один том.
nsrjb [<-j library_name>] -HH - or - nsrjb [<-j library_name>] -uvvvvv
- Определите компоновку библиотеки и убедитесь в ее готовности, сравнив информацию о состоянии NSR Jukebox с информацией о ленточном картридже робота:
nsrjb [<-j library_name>] -C sjirdtag <changer address>
- Попытайтесь загрузить (без монтирования) затронутую ленту на затронутый диск с высокой степенью детализации, а затем убедитесь, что дескриптор накопителя сообщает о наличии тома:
nsrjb [<-j library_name>] -lnvvvvv -f <device_handle> -S <slot_number> mt -f <device_handle> status
mt Подтверждение того, что дескриптор устройства не сообщает о громкости. Обычно это указывает на проблемы с упорядочиванием накопителей, особенно если загружается неожиданный дескриптор. Перейдите к разделу Поиск и устранение неисправностей при заказе накопителей в NetWorker .
Чтение этикетки носителя: логическая верификация
- Выполните автономную проверку этикеток, чтобы определить, был ли сбой чтения этикеток временным или постоянным:
nsrmm -pvvvvv -f <device_handle>
- Если метка действительно читабельна, то проблема, скорее всего, связана с логическими аспектами операций загрузки библиотек - см. Устранение проблем загрузки ленточной библиотеки в NetWorker.
- Выполните команду scan, чтобы определить, имеются ли какие-либо проблемы в части метки тома:
- Пометьте загруженное устройство как сервисное устройство, чтобы предотвратить его размонтирование
- Выполните команду:
scanner -nvvvvvv <device_handle>(запись в файл и отмена через 10 секунд) - Проверьте выходные данные сканера для ключевых элементов:
8936:scanner: scanning LTO Ultrium-3 tape 3FO3GR02 on /dev/rmt0.1 96367:scanner: volume id xxxxxxxx record size 262144 bytes created 7/10/13 1:01:24 expires 7/10/15 1:01:24 9003:scanner: /dev/rmt0.1: rewinding 9067:scanner: Rewinding done 8973:scanner: setting position from fn 0, rn 0 to fn 2, rn 0 9000:scanner: /dev/rmt0.1: opened for reading
- Проверьте вывод сканера на наличие критически важных фрагментов информации; Они представляют собой конфликтующие элементы при наличии ошибок повторяющихся меток .
wanted 2, got <not_2>, то проблема, скорее всего, заключается в том, что метка была перезаписана после перемотки, что почти всегда является результатом сброса SCSI. Следовать Поиск и устранение неисправностей с перезаписанными метками и сбросами SCSI в NetWorker.
Чтение этикетки носителя: физическая проверка (лента)
nsrmm -p, убедитесь, что начало ленты отформатировано правильно:
- Перемотайте ленту с помощью стандартной
mt(порт также доступен в Windows):mt -f <device> rewind - Скачайте и запустите
t_readerутилита и распаковка (используйте соответствующую платформу - все включено).t_readerдоступно в средствах NetWorker ( требуется учетная запись в службе поддержки Dell) - Запустите утилиту, указав локальный дескриптор и, при необходимости, самый большой размер блока на ленте, например:
t_reader/t_reader_AIX /dev/rmt0.1 262144
- Подождите несколько секунд, чтобы вывести изображение на экран. Убедитесь, что начало ленты отформатировано как метка NetWorker с ожидаемыми размерами блоков данных:
Found block size: 32768 File Mark encountered Found block size: 32768 File Mark encountered
Если структура этикетки кажется неповрежденной, проверьте, можно ли ее прочитать, или она кажется зашифрованной или иным образом скомпрометирована:
dd if=<device> of=<output file> bs=32768 count=2
Метка должна содержать неразборчивым и незашифрованным текстом имя тома, идентификатор тома и пул.
Дополнительные сведения см. в разделе Использование утилиты t_reader .
Чтение этикетки носителя: физическая проверка (диск)
Если проверка завершится ошибкой для сканера и nsrmm -p, проверьте целостность файла этикетки NetWorker, volhdr:
- Убедитесь, что файл volhdr доступен с хоста узла хранения, на котором возникли проблемы:
- Если дисковое устройство является локальным AFTD, убедитесь, что учетная запись, настроенная в ресурсе устройства nsr , может прочитать и скопировать
volhdr. - Если дисковое устройство является удаленным хранилищем CIFS/NFS, убедитесь, что учетная запись, настроенная в ресурсе устройства NSR , может читать и копировать
volhdr.
- Если дисковое устройство является локальным AFTD, убедитесь, что учетная запись, настроенная в ресурсе устройства nsr , может прочитать и скопировать
- Если
volhdrфайл присутствует и доступен для чтения, откройте его и просмотрите: Метка должна содержать неразборчивым и незашифрованным текстом имя тома, идентификатор тома и пул.
Если описанные выше тесты этикеток для затронутых устройств и носителей завершились успешно, но операции загрузки (монтирования) по-прежнему завершаются сбоем в производственной среде, см. раздел Поиск и устранение неисправностей загрузки ленточной библиотеки в NetWorker, чтобы продолжить поиск и устранение неисправностей.
Если ни одно из приведенных выше предложений не помогает, обратитесь в службу поддержки поставщика библиотеки, если доказательства, собранные в ходе отладки, указывают на какие-либо внутренние аномалии, как описано в разделах Устранение неполадок обнаружения ленточных библиотек в NetWorker и Поиск и устранение неисправностей доступа к ленточной библиотеке в NetWorker; В противном случае убедитесь, что выходные данные отладки эскалированы в NetWorker Support, чтобы исключить возможность дефекта кода.
Additional Information
Эта статья является частью серии Поиск и устранение неисправностей носителя в NetWorker. Список здесь:
NetWorker: домашняя страница в разделе Troubleshooting Tape Libraries