NetWorker:故障診斷媒體掛接問題

Summary: 本文旨在協助支援者和系統管理員判斷讀取磁帶或磁碟裝置標籤時發生問題的原因。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

如果磁帶庫配置以前有效,但突然遇到問題,請考慮可能影響標籤讀取和掛載的更改:

  • 機器人、開關或配接卡韌體、驅動程式或組態變更
  • 新增、更換或移除磁碟機、磁帶匣或其他磁帶庫元件
  • 任何加密元件的變更或事件 (例如 Decru 或加密金鑰管理員)
  • 變更 NetWorker 軟體版本或作業系統修補程式
  • 任何硬體事件,例如資料路徑中任何元件斷電或重新開機
  • NetWorker 組態與磁帶庫之間的差異 (例如,磁帶匣移出 NetWorker 控制之外)

如果標籤或磁碟區掛接從未成功 - 請在 NetWorker 硬體相容性指南中確認支援磁碟機硬體。請記住,設備可能部分功能正常;僅探索並不能保證可用性或支援性。
 

  • 嘗試載入或掛載媒體時偶爾或一致的錯誤
  • 無法在特定媒體上執行掛載或標記作業
  • 無法正確使用可移除或磁碟式媒體
  • 未使用靜態媒體,例如基於磁碟的裝置
  • 在 NSR 自動儲存塔物件中被標記為「未標記」的磁碟區
  • 儘管磁碟區位於磁帶庫中,但其位置欄位仍標記為 NULL 的磁碟區
  • 媒體裝入、標記或掃描器錯誤:
    • "Unexpected volume, wanted <volume_name>, got <different_volume_name>"
    • "Unexpected volid, wanted <mm_volid>, got <different_volid>
    • "Duplicate volume name `<volume_name>'. Select a new name or remove the original volume."
    • "scanner: Read -1 bytes"
    • "scanner: unexpected file number, wanted 2, got <different_number>"
    • "Opening the file '<disk_device_path>/volhdr' failed ([5004] nothing matched)"
    • "Waiting for <number> writable volume(s) to backup pool '<pool>' disk(s) or tape(s) on <storage_node>"
    • Warning: Required volume <volume>'s status is off-line"

    NetWorker 「掛接」作業包含數個子作業。檢閱以判斷掛接的哪個階段發生故障:

    1. NetWorker 選取要作業的磁碟區: 如需詳細資訊,請參閱 故障診斷 NetWorker 中的媒體選擇問題
    2. 如有需要,NetWorker 會將所選磁碟區載入裝置中: 如需詳細資訊,請參閱 故障診斷 NetWorker 中的磁帶庫載入問題
    3. 嘗試讀取標籤:
      • 磁碟裝置 - 的 volhdr 將檔案標示在磁碟裝置目錄根目錄下
      • 磁帶裝置(載入操作後) - 倒帶和讀取 媒體開頭 32KB 標籤區塊
      • 磁帶設備(寫入后,空閒,已載入) - 退格一個檔和第一條記錄的讀取塊頭
    4. 如果標籤讀取因任何原因而失敗,NetWorker 會阻止在任何重試嘗試中使用該卷:
      • 磁碟或獨立磁帶設備:卸載卷
      • 庫磁帶設備:卸載卷,將 nsr 自動儲存塔物件中的卷標籤條目更新為 *-(不在媒體索引中),並將媒體資料庫位置欄位更新為 NULL
    5. 如果讀取成功,請將標籤詳細資訊與「預期」值(所選卷的媒體資料庫卷記錄中的值)進行比較:
      • 磁碟區名稱
      • 磁碟區 ID
      • 媒體類型
    6. 如果經過驗證,磁碟區即會「掛接」,並認為可用於 NetWorker 的讀取或寫入作業:
      • 執行掛接的 nsr 裝置 物件已更新其 磁碟區 欄位 (例如磁碟區名稱、磁碟區 ID 等)。
      • 如果卷(和設備)是磁帶庫的成員,則 nsr 自動儲存塔物件將更新其相應的欄位(例如,載入的卷、載入的插槽、載入的條碼)。
    7. 如果驗證失敗,則傳回「意外」錯誤:
      • “意外的音量,想要 <volume_name>,得到了 <different_volume_name>
      • “出乎意料 volid、通緝 <mm_volid>,得到了 <different_volid>
      • 庫磁帶設備:卸載卷,並將 nsr 自動儲存塔 物件中的卷標籤條目更新為 *-(不在媒體索引中)

    封存 介質在邏輯上是獨立的,並且與 載入 介質不同。載入僅適用於將媒體移入裝置的邏輯 (也可能是實體) 作業。驗證媒體及其標籤,並使其邏輯上可供 NetWorker 使用的問題越來越多。庫操作 (nsrlcpd / NSR 自動儲存塔) 關注磁碟機元素:主機:裝置句柄對應和實體移動。驅動器操作 (nsrmmd / NSR 裝置) 處理所有讀取和寫入磁帶裝置 I/O。標籤讀取與寫入作業由 nsrsnmd。因此,看似磁帶庫 載入 故障可能是磁碟機、媒體或媒體資料庫 掛接 失敗 (或相反)。

    注意: 對於已掛載的磁碟媒體,新的儲存工作階段會導致 nsrmmd 在繼續保存流寫入 之前 驗證標籤。如果保存時間標籤檢查失敗,這可能會導致基於磁碟的卷定期卸載。

    另請注意,此簡單摘要不包括卷、節點或設備選擇邏輯的表示形式。
     

    Cause

    標籤讀取失敗的可能原因有很多:

    • 損毀的磁碟區
    • 標籤被倒帶覆寫
    • 磁碟機訂購問題
    • 媒體資料庫不匹配
    • CDI 錯誤
    • 無法解密加密磁碟區
    • 網路或環境問題導致暫時性 volhdr 檔案讀取失敗
    • libDDBoost 程式庫與 DD OS 版本之間不相容

     

    Resolution

    若要對標籤讀取和裝載問題進行故障排除,請在考慮上次已知更改(如果有)后,通過將進程下放到其原始成分並單獨測試它們來進行故障排除。

    雖然有用的資料是由以下人員收集的: NSRGet,這些操作大多需要人工執行。
     

    警告: 其中一些命令可能會導致 SCSI 重設,進而導致磁帶設備倒帶。如果有主機可存取的活動磁帶,請勿使用。

    圖書館機器人:通信

    • 同樣,請確保庫回應迅速且準備就緒,然後再繼續。如果沒有,請:

    無掛載的庫載入:邏輯操作和驅動器排序

    一旦我們確定物理操作沒有錯誤(至少表面上是這樣),我們就可以嘗試在 NetWorker 中跟蹤問題。

    • 從磁帶庫中的所有設備上卸載所有磁帶盒 - 確保僅掛載一個卷以避免混淆至關重要。
    nsrjb [<-j library_name>] -HH
    - or -
    nsrjb [<-j library_name>] -uvvvvv
    • 確定庫的佈局並確保其準備就緒,將 NSR 點唱機狀態資訊與機器人的磁帶盒資訊進行比較:
    nsrjb [<-j library_name>] -C
    sjirdtag <changer address>
    • 嘗試以高詳細程度將受影響的磁帶載入 (不掛載) 至受影響的磁碟機,然後確認磁碟機句柄報告磁碟區存在:
    nsrjb [<-j library_name>] -lnvvvvv -f <device_handle> -S <slot_number>
    mt -f <device_handle> status
    

    mt 確認裝置句柄報告沒有音量。這通常表示驅動器排序問題,尤其是在載入意外句柄時。請繼續 針對 NetWorker 的磁碟機訂購問題進行故障診斷

    媒體標籤讀取:邏輯驗證

    • 執行獨立的標籤驗證,以測試標籤讀取失敗是暫時性的還是一致的:
    nsrmm -pvvvvv -f <device_handle>
    • 如果標籤確實可讀取,則問題更有可能與磁帶庫載入作業的邏輯方面有關,請參閱 NetWorker 中的磁帶庫載入問題故障診斷
    • 執行掃描器命令,以判斷磁碟區的標籤部分是否存在任何問題:
    1. 在服務模式下標記已載入的裝置,以防止其卸載
    2. 在出現 ONIE 提示時,執行下列命令: scanner -nvvvvvv <device_handle> (擷取至檔案並在 10 秒後取消)
    3. 檢視掃描器輸出的關鍵項目:
    8936:scanner: scanning LTO Ultrium-3 tape 3FO3GR02 on /dev/rmt0.1
    96367:scanner: volume id xxxxxxxx record size 262144 bytes created  7/10/13  1:01:24 expires  7/10/15  1:01:24
    9003:scanner: /dev/rmt0.1: rewinding
    9067:scanner: Rewinding done
    8973:scanner: setting position from fn 0, rn 0 to fn 2, rn 0
    9000:scanner: /dev/rmt0.1: opened for reading
    • 檢查掃描器輸出的關鍵資訊;如果存在 重複的標籤 錯誤,這些代表衝突的元素。 wanted 2, got <not_2>,則問題可能是標籤在倒帶后被覆蓋,這幾乎總是 SCSI 重置的結果。關注在 NetWorker 中故障診斷覆寫標籤和 SCSI 重設

    媒體標籤讀取:物理驗證(磁帶)

    如果掃描器和 nsrmm -p,驗證磁帶的開頭格式是否正確:
    • 使用標準磁帶倒帶 mt 命令 (在 Windows 中也提供連接埠): mt -f <device> rewind
    • 下載並執行 t_reader 實用程式和數據提取(使用適當的平臺 - 全部包含在內)。 t_reader 可於 NetWorker 工具 使用 (需要 Dell 支援帳戶登入)
    • 執行公用程式,提供本機控制代碼,並選擇性地提供磁帶上的最大區塊大小,例如:
    t_reader/t_reader_AIX /dev/rmt0.1 262144
    • 允許運行幾秒鐘以獲得充滿輸出的螢幕。確認磁帶開頭的格式類似於 NetWorker 標籤,並採用預期的資料區塊大小:
    Found block size: 32768 
    File Mark encountered
    Found block size: 32768
    File Mark encountered

    如果標籤結構看起來完整無虞 - 看看它是否可以讀取,或者是否似乎被加密或以其他方式受損:

    dd if=<device> of=<output file> bs=32768 count=2

    標籤應以純文字包含磁碟區名稱、磁碟區 ID 和集區 (如果清晰可辨且未加密)。

    有關更多詳細資訊,請參閱 如何使用t_reader實用程式

    媒體標籤讀取:實體驗證(磁碟)

    如果掃描器和 nsrmm -p 檢查 NetWorker 標籤檔的完整性, volhdr

    • 檢查以確保 volhdr 檔案可從有問題的儲存節點主機存取:
      • 如果磁碟裝置是本機 AFTD,請確定在 nsr 裝置 資源中設定的帳戶可以讀取和複製 volhdr 檔案。
      • 如果磁碟裝置是遠端 CIFS/NFS,請確定在 nsr 裝置 資源中設定的帳戶可以讀取和複製 volhdr 檔案。
    • 如果 volhdr 檔案存在且可讀,請開啟並檢閱: 標籤應以純文字包含磁碟區名稱、磁碟區 ID 和集區 (若清晰可辨且未加密)。
    警告: 自動媒體管理。如果缺少磁帶的標籤,啟用了自動媒體管理的設備會在需要時自動標記媒體。當磁帶缺少標籤時,啟用了自動媒體管理的設備會自動分配標籤。默認情況下,磁碟設備的自動媒體管理的標記功能處於禁用狀態。


    如果上述標籤測試針對受影響的裝置和媒體成功,但在生產中載入 (和掛載) 作業仍持續失敗,請參閱故障 診斷 NetWorker 中的磁帶庫載入問題以繼續故障診斷。

    如果上述建議都沒有幫助,如果從調試中收集的證據顯示有任何內部異常,請根據需要聯繫您的庫供應商支援,例如 根據 NetWorker 中的磁帶庫檢測問題故障診斷NetWorker 中的磁帶庫訪問問題;否則,請確定偵錯輸出已在 NetWorker 支援中呈報,以追查發生程式碼瑕疵的可能性。

    Additional Information

    kA2j0000000R6jFCAS_5_0
    本文是故障診斷 NetWorker 媒體問題的系列文章之一。清單位於以下
    NetWorker:磁帶庫故障診斷首頁

    Affected Products

    NetWorker

    Products

    NetWorker
    Article Properties
    Article Number: 000071880
    Article Type: Solution
    Last Modified: 15 Jul 2026
    Version:  6
    Find answers to your questions from other Dell users
    Support Services
    Check if your device is covered by Support Services.