VxRail: Cannot Remove vSphere License Through vSphere Web Client

Summary: Customer cannot remove vSphere license through vSphere web client.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Customer cannot remove vSphere license through vSphere web client.
When you try to remove the license, an error may appears "storage error".

storage error


Cause

If the PSC or vCenter had an unexpected reboot, then you may see the PSC or vCenter needing a "fsck" check (File system check).

Resolution

For this situation, check these two things.
  1. Confirm if the PSC can be rebooted to verify if there is any OS partition issue. See Broadcom KB https://knowledge.broadcom.com/external/article?legacyId=2147154This hyperlink is taking you to a website outside of Dell Technologies.
  2. Login to the PSC node and run the command below to check the vmdir state: 
    /usr/lib/vmware-vmdir/bin/vdcadmintool
  3. If the vmdir state output is read only, use the command below to change vmdir state and check again: 
    "/usr/lib/vmware-vmafd/bin/dir-cli state set --state NORMAL --login administrator --password <password>"

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Affected Products

VxRail, VxRail Appliance Series
Article Properties
Article Number: 000185499
Article Type: Solution
Last Modified: 16 Oct 2024
Version:  2
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