Data Domain:SolarisのNetBackup 8.1でエラー ステータス84(メディア書き込みエラー)が報告される

Summary: Data Domain:この記事では、Solaris上のNetBackup 8.1でバックアップ エラー ステータス84(メディア書き込みエラー)が報告されることについて説明します。

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

SolarisでNetBackupを使用してDDVTL LTO-7ドライブでバックアップ ジョブを実行すると、次のエラーで失敗します。

Error bptm (pid=53194) FREEZING media id 0006L7, too many data blocks written, check tape/driver block size configuration
Info bptm (pid=53194) EXITING with status 84


これらのエラー メッセージは、NetBackupログ バンドルにあります。

Cause

より大きなI/O操作は、 st (テープ ドライバー)ドライバーの構成設定により、ドライバー レイヤーで分割されます。

一部のI/O操作では、1回のNetBackup書き込みにより、DDVTLで2つの分割ブロック書き込みが行われます。したがって、ブロック数に不一致が見られました。

vtcck 出力は、65536の1つのレコードが2つのレコードに分割されたことを示しています。つまり、1つのレコードサイズは65534バイトで、もう1つは2バイトのサイズです。

いくつかの操作に対して作成されたバイトサイズのレコードが2つあることがわかります。
 
21 data and 11 filemark records processed
Minimum record size: 2
Maximum record size: 65534
Average record size: 16140
Record Size    Number of Records
         2    1
       1024    11
      32768    8
      65534    1
      good: YES

Resolution

回避策は、「st.conf」を編集して再起動することです。

1.DDVTL LTO-7テープ ドライブでSolarisコマンド # mt config を実行します。
たとえば、 # mt -f /dev/rmt/0 config

次の結果(4番目のパラメーターを0x1065B)は、問題が存在することを示します。  
tape-config-list =
        "IBM     ULTRIUM-TD7", "IBM     ULTRIUM-TD7", "CFGIBMULTRIUMTD7";
        CFGIBMULTRIUMTD7 = 2,0x3B,0,0x1065B,4,0x00,0x00,0x00,0x00,0,120,120,3600,3600,3600,3600,3600;

2.Solarisファイル/kernel/drv/st.confを編集して、「tape-config-list」にST_NO_RECSIZE_LIMIT(0x8000)フラグを含めます。 
tape-config-list =
        "IBM     ULTRIUM-TD7", "IBM     ULTRIUM-TD7", "CFGIBMULTRIUMTD7";
        CFGIBMULTRIUMTD7 = 2,0x3B,0,0x1865B,4,0x00,0x00,0x00,0x00,0,120,120,3600,3600,3600,3600,3600;
3.再構成オプションを使用して再起動します。
# reboot -- -r

Affected Products

Data Domain
Article Properties
Article Number: 000213846
Article Type: Solution
Last Modified: 15 Sept 2023
Version:  2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.