NetWorker: SQL backup fails with Cannot login to SQL Server

Summary: The NetWorker Module for Microsoft (NMM) SQL Server backup fails with "Cannot login to SQL Server". The Modify Client Wizard report the error, "Referenced object does not exist".

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The NetWorker Module for Microsoft (NMM) SQL Server backup fails.   The symptoms of this issue include:

  • The backup fails with the following error:
nsrsqlsv NSR critical Cannot login to SQL Server Default Instance. 38008:nsrsqlsv: Named Pipes Provider: Could not open a connection to SQL Server [2].
  • When the client resource is modified with Modify Client wizard, the backup set selection produces a window with the error "Referenced object does not exist.

Cause

  • The root cause of this issue is that the SQL Server service was not running.

Resolution

  • To resolve this issue, contact the database administrator to restart the SQL Server services.
Article Properties
Article Number: 000230330
Article Type: Solution
Last Modified: 07 Feb 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.