PowerStore: Přidání aplikace XtremIO jako vzdáleného systému se nezdaří s sys_not_found
Summary: Přidání softwaru Dell EMC XtremIO do zařízení PowerStore jako vzdáleného systému pro import dat selže s chybou: Nelze získat podrobnosti o clusteru XtremIO [sys_not_found].
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Přidání softwaru XtremIO jako vzdáleného systému pro import dat selže s chybou sys_not_found.
Odpovídající chybová zpráva v protokolu XtremIO xms.log zobrazuje úspěšné přihlášení se stejnou chybovou zprávou, která je přesměrována do zařízení PowerStore:
Mar 25 12:52:33 xxxxx-A control-path[95525]: xx [DATAMOBILITY] [INFO] [com.emc.cyclone.contexts.datamobility.services.remotesystem.CreateRemoteSystemAS|vert.x-eventloop-thread-0] [xx] Creating remote system: {
"create_remote_peer" : false,
"management_address" : "",
"name" : "",
"description" : "",
"remote_username" : "",
"type" : "XtremIO",
"discovery_chap_mode" : "Disabled",
"session_chap_mode" : "Disabled",
"iscsi_addresses" : [ "" ],
"data_network_latency" : "Low",
"_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_type" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_class_name" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_metadata" : {
"REST-Request-ID" : "723fcf20-6aa5-4bb0-b1e3-b97cf2252e29",
"httpQueryParams" : { },
"isAutoAcknowledge" : true,
"persisted" : true,
"isDupe" : false
},
"routing_metadata" : {
"source_location" : "CLUSTER_MASTER"
},
"executionLocation" : "CLUSTER_MASTER",
"command_state" : "RUNNING",
"priority" : "DEFAULT",
"is_cancellable" : false,
"is_async" : false,
"customauth" : "",
"userRole" : "Administrator",
"client_address" : "",
"user_name" : "",
"root_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_description" : "...",
"is_restartable" : true,
"is_encrypted" : true,
"is_internal" : false,
"resource_type" : "remote_system",
"canQueue" : true,
"retention_period" : 0,
"resource_action" : "create",
"work_unit_id" : "972e5c12-9920-44d6-822d-daad0a05c85c"
}
...
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] XtremIO REST error response for REST API: /api/json/v3/types/clusters?cluster-name=&full=1∝=sys-psnt-serial-number∝=sys-sw-version∝=sys-state∝=sys-id∝=hardware-platform∝=obj-severity∝=chap-discovery-mode∝=chap-authentication-mode and XtremIO: xx.xx.xx.xx : io.vertx.ext.web.client.impl.HttpResponseImpl@5166a6ff
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] getSystemDetails failed for XtremIO:
Unable to get XtremIO cluster details [sys_not_found].
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.createAdapterException(XtremIOAdapterImpl.java:1350)
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.lambda$getSystemDetails$13(XtremIOAdapterImpl.java:340)
at io.reactivex.internal.operators.single.SingleResumeNext$ResumeMainSingleObserver.onError(SingleResumeNext.java:73)
at io.reactivex.internal.operators.single.SingleDoOnSuccess$DoOnSuccess.onError(SingleDoOnSuccess.java:65)
at io.reactivex.internal.operators.single.SingleMap$MapSingleObserver.onError(SingleMap.java:69)
...
Odpovídající chybová zpráva v protokolu XtremIO xms.log zobrazuje úspěšné přihlášení se stejnou chybovou zprávou, která je přesměrována do zařízení PowerStore:
2022-03-25 12:53:34 - XmsLogger[13466:fd60::RSTe19a2a:RSTc0d68c] - INFO - context::auth:172 - User authentication successful. user: , IP:
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - INFO - context::auth:172 - User authentication successful. user: , IP:
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - ERROR - context::process_wrapper:285 - Caught exception in query process:
Traceback (most recent call last):
File "xms/context.py", line 283, in process_wrapper
File "xms/context.py", line 265, in actual_command
File "xms/common_server.py", line 151, in execute_command
File "xms/executor.py", line 825, in query
File "xms/executor.py", line 852, in _query
File "xms/models/mom/object_id.py", line 571, in get_system
RpcFault:
2022-03-25 12:53:34 - XmsLogger[3746:99e6::RSTa17440] - ERROR - rest_server::handle_error:375 - rest_server error: Traceback (most recent call last):
File "/xtremapp/xms/python27_env/lib/python2.7/site-packages/twisted/internet/defer.py", line 653, in _runCallbacks
current.result = callback(current.result, *args, **kw)
File "xms/executor.py", line 423, in command_cb_eb
RpcFault: 2022-03-25 12:53:34,872 - XmsLogger[13480:6b71::JESac59f1] - INFO - esrsve_tasks::run:174 - Sent SYR using MFT
Cause
K tomu dochází, pokud název uvedený v průvodci přidáním vzdáleného systému zařízení PowerStore neodpovídá názvu nastavenému v systému XtremIO.
Resolution
V průvodci použijte skutečný název XtremIO.
Název clusteru XtremIO naleznete:
Název clusteru XtremIO naleznete:
- Pomocí webového rozhraní XtremIO v části Inventory > Clusters
- Pomocí příkazového řádku pomocí příkazu: xmcli (tech) > show-clusters
Additional Information
Požadavky a omezení importu jsou uvedeny v dokumentu Importování externího úložiště do zařízení PowerStore v https://www.dell.com/powerstoredocs.
Pokud vzdálený systém XtremIO po úspěšném přidání do zařízení PowerStore hlásí úplnou ztrátu datového připojení a můžete odeslat příkaz ping na porty iSCSI, ověřte, zda připojení mezi softwarem XtremIO a zařízením PowerStore funguje a přihlašovací údaje jsou platné.
Zařízení PowerStore používá pro import síť označenou replikací.
Pokud je nutné změnit štítek replikace na jinou síť, odeberte vzdálený systém XtremIO, změňte číslo replikace a přidejte jej znovu.
Pokud vzdálený systém XtremIO po úspěšném přidání do zařízení PowerStore hlásí úplnou ztrátu datového připojení a můžete odeslat příkaz ping na porty iSCSI, ověřte, zda připojení mezi softwarem XtremIO a zařízením PowerStore funguje a přihlašovací údaje jsou platné.
Zařízení PowerStore používá pro import síť označenou replikací.
Pokud je nutné změnit štítek replikace na jinou síť, odeberte vzdálený systém XtremIO, změňte číslo replikace a přidejte jej znovu.
Affected Products
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9000XArticle Properties
Article Number: 000198206
Article Type: Solution
Last Modified: 11 Apr 2022
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.