PowerStore: Adding XtremIO as remote system fails with sys_not_found
Summary: Adding a Dell EMC XtremIO to PowerStore as a remote system for data import fails with the error: Unable to get XtremIO cluster details [sys_not_found].
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Symptoms
Adding an XtremIO as a remote system for data import, fails with the error sys_not_found.
The corresponding error message on the XtremIO xms.log showing a successful login, with the same error message that is forwarded to the PowerStore:
Mar 25 12:52:33 xxxxx-A control-path[95525]: xx [DATAMOBILITY] [INFO] [com.emc.cyclone.contexts.datamobility.services.remotesystem.CreateRemoteSystemAS|vert.x-eventloop-thread-0] [xx] Creating remote system: {
"create_remote_peer" : false,
"management_address" : "<ManagementIP>",
"name" : "<XtremIO Name>",
"description" : "",
"remote_username" : "<XtremIO UserName>",
"type" : "XtremIO",
"discovery_chap_mode" : "Disabled",
"session_chap_mode" : "Disabled",
"iscsi_addresses" : [ "<iSCSI IP>" ],
"data_network_latency" : "Low",
"_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_type" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_class_name" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_metadata" : {
"REST-Request-ID" : "723fcf20-6aa5-4bb0-b1e3-b97cf2252e29",
"httpQueryParams" : { },
"isAutoAcknowledge" : true,
"persisted" : true,
"isDupe" : false
},
"routing_metadata" : {
"source_location" : "CLUSTER_MASTER"
},
"executionLocation" : "CLUSTER_MASTER",
"command_state" : "RUNNING",
"priority" : "DEFAULT",
"is_cancellable" : false,
"is_async" : false,
"customauth" : "<XtremIO UserName>",
"userRole" : "Administrator",
"client_address" : "<>",
"server_address" : "<>",
"user_name" : "<XtremIO UserName>",
"root_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_description" : "...",
"is_restartable" : true,
"is_encrypted" : true,
"is_internal" : false,
"resource_type" : "remote_system",
"canQueue" : true,
"retention_period" : 0,
"resource_action" : "create",
"work_unit_id" : "972e5c12-9920-44d6-822d-daad0a05c85c"
}
...
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] XtremIO REST error response for REST API: /api/json/v3/types/clusters?cluster-name=<XtremIO Name>&full=1&prop=sys-psnt-serial-number&prop=sys-sw-version&prop=sys-state&prop=sys-id&prop=hardware-platform&prop=obj-severity&prop=chap-discovery-mode&prop=chap-authentication-mode and XtremIO: xx.xx.xx.xx : io.vertx.ext.web.client.impl.HttpResponseImpl@5166a6ff
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] getSystemDetails failed for XtremIO: <XtremIO Name>
Unable to get XtremIO cluster details [sys_not_found].
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.createAdapterException(XtremIOAdapterImpl.java:1350)
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.lambda$getSystemDetails$13(XtremIOAdapterImpl.java:340)
at io.reactivex.internal.operators.single.SingleResumeNext$ResumeMainSingleObserver.onError(SingleResumeNext.java:73)
at io.reactivex.internal.operators.single.SingleDoOnSuccess$DoOnSuccess.onError(SingleDoOnSuccess.java:65)
at io.reactivex.internal.operators.single.SingleMap$MapSingleObserver.onError(SingleMap.java:69)
...
The corresponding error message on the XtremIO xms.log showing a successful login, with the same error message that is forwarded to the PowerStore:
2022-03-25 12:53:34 - XmsLogger[13466:fd60::RSTe19a2a:RSTc0d68c] - INFO - context::auth:172 - User authentication successful. user: <XtremIO UserName>, IP: <PowerStore Management IP>
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - INFO - context::auth:172 - User authentication successful. user: <XtremIO UserName>, IP: <PowerStore Management IP>
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - ERROR - context::process_wrapper:285 - Caught exception in query process:
<Fault 600: 'sys_not_found'>
Traceback (most recent call last):
File "xms/context.py", line 283, in process_wrapper
File "xms/context.py", line 265, in actual_command
File "xms/common_server.py", line 151, in execute_command
File "xms/executor.py", line 825, in query
File "xms/executor.py", line 852, in _query
File "xms/models/mom/object_id.py", line 571, in get_system
RpcFault: <Fault 600: 'sys_not_found'>
2022-03-25 12:53:34 - XmsLogger[3746:99e6::RSTa17440] - ERROR - rest_server::handle_error:375 - rest_server error: Traceback (most recent call last):
File "/xtremapp/xms/python27_env/lib/python2.7/site-packages/twisted/internet/defer.py", line 653, in _runCallbacks
current.result = callback(current.result, *args, **kw)
File "xms/executor.py", line 423, in command_cb_eb
RpcFault: <Fault 600: 'sys_not_found'>2022-03-25 12:53:34,872 - XmsLogger[13480:6b71::JESac59f1] - INFO - esrsve_tasks::run:174 - Sent SYR using MFT
Cause
This happens if the name provided on the PowerStore's add remote system wizard does not match the name set up on the XtremIO system.
Resolution
Use the real XtremIO's name on the Wizard.
The XtremIO cluster name can be found:
The XtremIO cluster name can be found:
- Using the XtremIO web interface, under Inventory > Clusters
- Using the CLI with the command: xmcli (tech)> show-clusters
Additional Information
Import requirements and restrictions are listed in the Importing External Storage to PowerStore document on https://www.dell.com/powerstoredocs.
If the XtremIO remote system reports a complete data connection loss after successfully adding it to the PowerStore, and you can ping the iSCSI ports, verify that connectivity on both management and storage network between the XtremIO and PowerStore is working, and login credentials are valid.
PowerStore uses the replication-tagged network for imports.
If you have to change the replication tag to a different network, remove the XtremIO remote system, change the replication tag, and then add it again.
If the XtremIO remote system reports a complete data connection loss after successfully adding it to the PowerStore, and you can ping the iSCSI ports, verify that connectivity on both management and storage network between the XtremIO and PowerStore is working, and login credentials are valid.
PowerStore uses the replication-tagged network for imports.
If you have to change the replication tag to a different network, remove the XtremIO remote system, change the replication tag, and then add it again.
Affected Products
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9000XArticle Properties
Article Number: 000198206
Article Type: Solution
Last Modified: 11 Apr 2022
Version: 1
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