PowerStore: Додавання XtremIO як віддаленої системи не вдається з sys_not_found
Summary: Додавання Dell EMC XtremIO в PowerStore в якості віддаленої системи для імпорту даних не вдається з помилкою: Не вдається отримати відомості про кластер XtremIO [sys_not_found].
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Додавання XtremIO в якості віддаленої системи для імпорту даних, не вдається з помилкою sys_not_found.
Відповідне повідомлення про помилку на XtremIO xms.log що показує успішний вхід, з тим же повідомленням про помилку, яке пересилається в PowerStore:
Mar 25 12:52:33 xxxxx-A control-path[95525]: xx [DATAMOBILITY] [INFO] [com.emc.cyclone.contexts.datamobility.services.remotesystem.CreateRemoteSystemAS|vert.x-eventloop-thread-0] [xx] Creating remote system: {
"create_remote_peer" : false,
"management_address" : "",
"name" : "",
"description" : "",
"remote_username" : "",
"type" : "XtremIO",
"discovery_chap_mode" : "Disabled",
"session_chap_mode" : "Disabled",
"iscsi_addresses" : [ "" ],
"data_network_latency" : "Low",
"_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_type" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_class_name" : "com.emc.cyclone.contexts.datamobility.commands.remotesystem.CreateRemoteSystemCommand",
"command_metadata" : {
"REST-Request-ID" : "723fcf20-6aa5-4bb0-b1e3-b97cf2252e29",
"httpQueryParams" : { },
"isAutoAcknowledge" : true,
"persisted" : true,
"isDupe" : false
},
"routing_metadata" : {
"source_location" : "CLUSTER_MASTER"
},
"executionLocation" : "CLUSTER_MASTER",
"command_state" : "RUNNING",
"priority" : "DEFAULT",
"is_cancellable" : false,
"is_async" : false,
"customauth" : "",
"userRole" : "Administrator",
"client_address" : "",
"user_name" : "",
"root_id" : "c5806950-7bdb-4d1b-a710-f518f6e09fc8",
"command_description" : "...",
"is_restartable" : true,
"is_encrypted" : true,
"is_internal" : false,
"resource_type" : "remote_system",
"canQueue" : true,
"retention_period" : 0,
"resource_action" : "create",
"work_unit_id" : "972e5c12-9920-44d6-822d-daad0a05c85c"
}
...
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] XtremIO REST error response for REST API: /api/json/v3/types/clusters?cluster-name=&full=1∝=sys-psnt-serial-number∝=sys-sw-version∝=sys-state∝=sys-id∝=hardware-platform∝=obj-severity∝=chap-discovery-mode∝=chap-authentication-mode and XtremIO: xx.xx.xx.xx : io.vertx.ext.web.client.impl.HttpResponseImpl@5166a6ff
Mar 25 12:52:34 xxxxx-A control-path[95525]: [ERROR] [com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl|vert.x-eventloop-thread-2] [] getSystemDetails failed for XtremIO:
Unable to get XtremIO cluster details [sys_not_found].
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.createAdapterException(XtremIOAdapterImpl.java:1350)
at com.emc.cyclone.contexts.destinationcyclone.infrastructure.adapters.storage.xio.impl.XtremIOAdapterImpl.lambda$getSystemDetails$13(XtremIOAdapterImpl.java:340)
at io.reactivex.internal.operators.single.SingleResumeNext$ResumeMainSingleObserver.onError(SingleResumeNext.java:73)
at io.reactivex.internal.operators.single.SingleDoOnSuccess$DoOnSuccess.onError(SingleDoOnSuccess.java:65)
at io.reactivex.internal.operators.single.SingleMap$MapSingleObserver.onError(SingleMap.java:69)
...
Відповідне повідомлення про помилку на XtremIO xms.log що показує успішний вхід, з тим же повідомленням про помилку, яке пересилається в PowerStore:
2022-03-25 12:53:34 - XmsLogger[13466:fd60::RSTe19a2a:RSTc0d68c] - INFO - context::auth:172 - User authentication successful. user: , IP:
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - INFO - context::auth:172 - User authentication successful. user: , IP:
2022-03-25 12:53:34 - XmsLogger[13472:47a0::RSTa17440:RSTbf36d3] - ERROR - context::process_wrapper:285 - Caught exception in query process:
Traceback (most recent call last):
File "xms/context.py", line 283, in process_wrapper
File "xms/context.py", line 265, in actual_command
File "xms/common_server.py", line 151, in execute_command
File "xms/executor.py", line 825, in query
File "xms/executor.py", line 852, in _query
File "xms/models/mom/object_id.py", line 571, in get_system
RpcFault:
2022-03-25 12:53:34 - XmsLogger[3746:99e6::RSTa17440] - ERROR - rest_server::handle_error:375 - rest_server error: Traceback (most recent call last):
File "/xtremapp/xms/python27_env/lib/python2.7/site-packages/twisted/internet/defer.py", line 653, in _runCallbacks
current.result = callback(current.result, *args, **kw)
File "xms/executor.py", line 423, in command_cb_eb
RpcFault: 2022-03-25 12:53:34,872 - XmsLogger[13480:6b71::JESac59f1] - INFO - esrsve_tasks::run:174 - Sent SYR using MFT
Cause
Це трапляється, якщо ім'я, вказане в майстрі додавання віддаленої системи PowerStore, не збігається з іменем, встановленим у системі XtremIO.
Resolution
Використовуйте справжнє ім'я XtremIO у майстрі.
Назву кластера XtremIO можна знайти:
Назву кластера XtremIO можна знайти:
- За допомогою веб-інтерфейсу XtremIO в розділі Inventory > Clusters
- За допомогою командного рядка командою: xmcli (tech)> show-clusters
Additional Information
Вимоги та обмеження імпорту перелічено в документі «Імпорт зовнішнього сховища до PowerStore » на https://www.dell.com/powerstoredocs.
Якщо віддалена система XtremIO повідомляє про повну втрату з'єднання з даними після успішного додавання її до PowerStore, і ви можете пропінгувати порти iSCSI, переконайтеся, що підключення як в керуванні, так і в мережі зберігання між XtremIO і PowerStore працює, і що облікові дані для входу дійсні.
PowerStore використовує мережу з тегами реплікації для імпорту.
Якщо потрібно змінити тег реплікації на іншу мережу, видаліть віддалену систему XtremIO, змініть тег реплікації, а потім додайте його знову.
Якщо віддалена система XtremIO повідомляє про повну втрату з'єднання з даними після успішного додавання її до PowerStore, і ви можете пропінгувати порти iSCSI, переконайтеся, що підключення як в керуванні, так і в мережі зберігання між XtremIO і PowerStore працює, і що облікові дані для входу дійсні.
PowerStore використовує мережу з тегами реплікації для імпорту.
Якщо потрібно змінити тег реплікації на іншу мережу, видаліть віддалену систему XtremIO, змініть тег реплікації, а потім додайте його знову.
Affected Products
PowerStore 1000X, PowerStore 1000T, PowerStore 3000X, PowerStore 3000T, PowerStore 5000X, PowerStore 5000T, PowerStore 500T, PowerStore 7000X, PowerStore 7000T, PowerStore 9000TProducts
PowerStore 9000XArticle Properties
Article Number: 000198206
Article Type: Solution
Last Modified: 11 Apr 2022
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.