PowerProtect: File Level Recovery (FLR) fails with Access Denied error while browsing

Summary: Using PowerProtect Data Manager to recover files to a Windows VMware Virtual Machine (VM) the FLR process fails to browse folders and posts an access denied error.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Browsing the folders after the mount procedure completes produces an error similar to the following:
 

400: Failed to update FLR session. Could not get directory contents. Unable to retrieve file list from IP_of_VM (vm-######) path 'C:\Folder_Name' offset 0. Unable to perform FLR Agent operation 'browse_files' on VM IP_of_VM (vm-######). Cannot open 'C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR##########\00-C$\Folder_Name': open C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR##########\00-C$\Folder_Name: Access is denied.

Cause

The error indicates a permissions issue with the account used to initiate the FLR. It does not have permissions in Windows to access those files and folders.

Resolution

There are several ways to resolve this permissions issue:

A. Change the account used to initiate the FLR to one that has either local or Domain admin permissions on that Windows VM host.
B. Set the option "Run with Elevated Privileges"
C. A manual workaround is to recover the files directly on the Target VM host:

  1. Log in to the target VM that the files are being recovered to using either a local or Domain Administrator level account.
  2. Use Windows Explorer and browse to the wanted folder:  C:\Program Files (x86)\EMC\vProxy FLR Agent\flr\mountpoints\FLR##########\00-C$\Folder_Name 
    Note:  The FLR########## folder name changes each time an FLR operation is run, it is a job ID.
  3. Manually copy the needed files or folders to the intended location.
  4. Go back to the PowerProtect Data Manager UI and cancel the recovery once the files have been restored.
     

Affected Products

PowerProtect Data Manager Software
Article Properties
Article Number: 000224891
Article Type: Solution
Last Modified: 04 Sept 2025
Version:  2
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