VPLEX error: Failed to flush writer, No space left on device

Summary: This article details an issue where the VPLEX health-check command reports log4j: ERROR 'Failed to flush writer, cause: No space left on device'. This article provides the workaround steps to resolve the issue. ...

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

VPLEX health-check command reports the following error:

VPlexcli:/> health-check
log4j:ERROR Failed to flush writer,
cause: No space left on device
Product Version: 5.5.2.02.00.03
Product Type: Metro
WAN Connectivity Type: FC
Hardware Type: VS2
Cluster Size: 2 engines
Cluster TLA:
cluster-1: CKM00xxxxxxxxx
cluster-2: CKM00xxxxxxxxx

Cluster    Cluster  Oper   Health    Connected  Expelled  Local-com  
Name       ID       State  State                                     
---------  -------  -----  --------  ---------  --------  ---------  
cluster-1  1        ok     ok        True       False     ok
cluster-2  2        ok     degraded  True       False     ok


File cleanup is required to reduce the /var/log directory partition level.
 

Cause

No space is left on the /var/log directory. The partition level has reached 100%:

service@vplexnkdc01:~> df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.8G   11G  44% /
udev            1.9G  184K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda1       504M   76M  403M  16% /boot
/dev/sda7        16G   16G     0 100% /var/log   <<<<<<<<<<<<<<<<<<
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  151M  9.2G   2% /data

Resolution

Workaround:
To check the partition usage, type the df-h command at the management server prompt:

Service@ManagementServer:~> df-h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.8G   11G  44% /
udev            1.9G  184K  1.9G   1% /dev
tmpfs           1.9G     0  1.9G   0% /dev/shm
/dev/sda1       504M   76M  403M  16% /boot
/dev/sda7        16G   16G     0 100% /var/log    <<<<<<<<<<<<<<<
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  151M  9.2G   2% /data


Troubleshooting steps:

  1. Refer to the below knowledge base article to reduce the partition level: VPLEX: 0x8a4a91fa / 0x8a4a31fb Management Server partitions full or exceeded xx Management Server partitions full
    If the /var/log usage remains above the threshold, after following the knowledgebase article, then follow step 2.
  2. There could be more than one issue which caused the /var/log/ folder on the management server to fill to 100% due to net-snmpd.log not rotating properly.
    Verify the net-snmpd.log log utilization on /var/log context. If the net-snmpd.log consumes more usage, then you must reload or restart the net-snmpd log.
    Refer to the knowledge base articles to rotate/reload the net-snmpd.log:
    VPLEX: /var/log/ filling up due to net-snmpd.log not rotating properly
  3. Check disk space to ensure that the change is reflected:
ManagementServer:/var/log # df -h
Filesystem      Size  Used Avail Use% Mounted on
/dev/sda5        20G  7.3G   11G  41% /
udev            1.9G  136K  1.9G   1% /dev
tmpfs           1.9G   68M  1.8G   4% /dev/shm
/dev/sda1       504M  111M  368M  24% /boot
/dev/sda7        16G  2.4G   13G  16% /var/log
/dev/sda8        44G   27G   16G  64% /diag
/dev/sda9       9.9G  260M  9.1G   3% /data
  1. If after following these actions, the issue still persists, contact Dell Customer Service and refer to this article.

Affected Products

VPLEX, VPLEX GeoSynchrony

Products

VPLEX VS2, VPLEX VS6
Article Properties
Article Number: 000168666
Article Type: Solution
Last Modified: 12 Dec 2025
Version:  3
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