Systèmes Data Domain avec les versions 7.7.1.0, 7.7.2.0, 7.8.0.0 et 7.8.0.10. Problème de perte de données potentielle lors de l'écriture des sauvegardes pendant l'exécution du cycle de nettoyage
Summary: Les systèmes Data Domain (DDR, DDVE et DDVE dans le Cloud) exécutant les versions 7.7.1.0, 7.7.2.0, 7.8.0.0 et 7.8.0.10 du DDOS peuvent subir une perte de données potentielle lorsque des sauvegardes sont écrites pendant le nettoyage, en raison d'une condition de concurrence rare. ...
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Symptoms
Les données peuvent être supprimées du système de manière incorrecte pendant le cycle de nettoyage. La sauvegarde ne peut plus être entièrement lue. Lorsque ce problème se produit, Data Domain Restorer (DDR) peut présenter un ou plusieurs des éléments suivants :
- Alerte indiquant que la corruption a été trouvée sur le disque :
Id Post Time Severity Class Object Message
----- ------------------------ -------- ---------- ----------- ------------------------------------------------------------------
m0-32 Wed Jun 29 05:19:16 2022 CRITICAL Filesystem Tier=Active EVT-FILESYS-00020: Corruption has been detected in the filesystem.
- Des redémarrages non planifiés du système de fichiers Data Domain (DDFS) si le fichier concerné est lu par la restauration, la réplication, le déplacement des données vers le Cloud ou le cycle de nettoyage.
PÉRIMÈTRE DE L'IMPACT
- Systèmes potentiellement concernés : systèmes DDR, DDVE et DDVE dans le Cloud exécutant les versions 7.7.1.0, 7.7.2.0, 7.8.0.0 et 7.8.0.10 de DDOS. Les systèmes exécutant d'autres versions de DDOS ne sont pas affectés.
- Les sauvegardes existantes qui sont écrites dans une version antérieure du DDOS ne sont pas affectées.
- Les sauvegardes hiérarchisées vers le Cloud réalisées à l'aide de déplacements des données ne sont pas affectées.
- Si la vérification des fichiers concernait les sauvegardes après la date/l'heure de fin du dernier nettoyage et qu'aucune alerte « Corruption Detected » n'est publiée, alors aucune sauvegarde n'est affectée.
- Si toutes les sauvegardes ont été répliquées avec succès, la source de réplication Data Domain n'est pas affectée.
Cause
Le problème se produit en raison d'une condition de concurrence rare.
Resolution
Ce problème est résolu dans les versions DDOS 7.7.1.10, 7.7.2.10, 7.8.0.20 et ultérieures.
Choisissez parmi les versions actuelles disponibles sur le portail de téléchargement pour intégrer des correctifs supplémentaires et les failles de sécurité les plus récentes.
Suivez les deux sections ci-dessous :
(I) Comment éviter l'impact sur de nouvelles sauvegardes
(II) Vérification de l'intégrité des données et mesures correctives.
(I) Comment éviter l'impact sur de nouvelles sauvegardes
. L'action recommandée consiste à installer une version DDOS contenant le correctif pour ce problème. Si la version DDOS avec le correctif est installée, aucune autre action n'est nécessaire dans cette section (I).
OU
Si vous ne pouvez pas installer immédiatement la version DDOS avec le correctif, poursuivez avec (I) :
Exemple :
(II) Vérification de l'intégrité des données et mesures correctives
L'architecture Data Domain garantit l'intégrité de toutes les sauvegardes écrites. Si la vérification d'une sauvegarde échoue, une alerte est publiée. L'horodatage du dernier fichier vérifié indique la date et l'heure auxquelles tous les fichiers ont été vérifiés. Si « l'horodatage du dernier fichier vérifié » est ultérieur au dernier cycle de nettoyage ET qu'il n'y a aucune alerte « Corruption Detected », alors aucune sauvegarde n'est affectée.
Choisissez parmi les versions actuelles disponibles sur le portail de téléchargement pour intégrer des correctifs supplémentaires et les failles de sécurité les plus récentes.
Suivez les deux sections ci-dessous :
(I) Comment éviter l'impact sur de nouvelles sauvegardes
(II) Vérification de l'intégrité des données et mesures correctives.
(I) Comment éviter l'impact sur de nouvelles sauvegardes
. L'action recommandée consiste à installer une version DDOS contenant le correctif pour ce problème. Si la version DDOS avec le correctif est installée, aucune autre action n'est nécessaire dans cette section (I).
OU
Si vous ne pouvez pas installer immédiatement la version DDOS avec le correctif, poursuivez avec (I) :
1. Désactivez la planification de nettoyage.
2. Si vous devez effectuer le nettoyage pour réduire les problèmes de capacité, désactivez toutes les ingestions avant le nettoyage.
# filesys clean set schedule never Filesystem cleaning is scheduled to run "never". Stop current Clean cycle if running # filesys clean status Cleaning started at 2022/06/27 12:32:03: phase 4 of 6 (pre-select) 8.7% complete, 438 GiB free; time: phase 0:00:01, total 0:10:35 # filesys clean stop The 'filesys clean stop' command stops the filesystem cleaning. Are you sure? (yes|no) [no]: yes ok, proceeding.
2. Si vous devez effectuer le nettoyage pour réduire les problèmes de capacité, désactivez toutes les ingestions avant le nettoyage.
2a. Désactivez les sauvegardes/clonages depuis l'application de sauvegarde.
2b. Désactivez les protocoles sur Data Domain.
2b. Désactivez les protocoles sur Data Domain.
# replication disable all # nfs disable # cifs disable # ddboost disable # vtl disable
2c. Exécutez le nettoyage et surveillez le processus comme suit :
2d. Une fois que le nettoyage entre dans la phase 2 (préanalyse), réactivez la planification des sauvegardes et les protocoles.
# filesys clean start Active tier cleaning started. Use 'filesys clean watch' to monitor progress. # filesys clean watch Beginning 'filesys clean' monitoring. Use Control-C to stop monitoring. Cleaning: phase 1 of 6 (pre-merge) 100.0% complete, 438 GiB free; time: phase 0:00:42, total 0:00:42- Cleaning: phase 2 of 6 (pre-analysis) 3.3% complete, 438 GiB free; time: phase 0:00:16, total 0:00:59
2d. Une fois que le nettoyage entre dans la phase 2 (préanalyse), réactivez la planification des sauvegardes et les protocoles.
# replication enable all # nfs enable # cifs enable # ddboost enable # vtl enable
Remarque : une fois la version DDOS avec le correctif installée, réinitialisez la planification de nettoyage.
Exemple :
# filesys clean set schedule Tue,0600
(II) Vérification de l'intégrité des données et mesures correctives
L'architecture Data Domain garantit l'intégrité de toutes les sauvegardes écrites. Si la vérification d'une sauvegarde échoue, une alerte est publiée. L'horodatage du dernier fichier vérifié indique la date et l'heure auxquelles tous les fichiers ont été vérifiés. Si « l'horodatage du dernier fichier vérifié » est ultérieur au dernier cycle de nettoyage ET qu'il n'y a aucune alerte « Corruption Detected », alors aucune sauvegarde n'est affectée.
1. Vérifiez s'il existe une alerte d'intégrité des données.
L'alerte ressemble à ce qui suit :
Si une alerte d'intégrité des données est détectée, contactez immédiatement le support client Dell Technologies.
CRITICAL Filesystem Tier=Active EVT-FILESYS-00020: Corruption has been detected in the filesystem. Check for current alerts with the command below: # alerts show current
Si une alerte d'intégrité des données est détectée, contactez immédiatement le support client Dell Technologies.
2. Si aucune alerte d'intégrité des données n'est publiée, vérifiez l'heure de fin du dernier nettoyage et l'horodatage de la vérification du fichier.
2a. Vérifiez l'heure du dernier nettoyage :
# filesys clean status Cleaning finished at 2022/06/24 16:36:01.
2b. Vérifiez l'horodatage de la vérification du fichier (FV) :
Accédez au mode SE :
# priv set se Enter system password: <Enter Serial Num> # se grep "Last Verified file timestamp:" /ddr/var/support/autosupport Last Verified file timestamp: Sat Jun 25 23:00:22 2022 Verify threads running: 1
- Lorsque l'horodatage de la vérification du fichier (FV) est ultérieur à la date et à l'heure du dernier cycle de nettoyage, alors aucune sauvegarde n'est affectée.
- Lorsque l'horodatage FV est antérieur à la date/heure du dernier cycle de nettoyage d'une semaine ou moins, attendez qu'il se remette à niveau et vérifiez à nouveau.
Remarque : l'horodatage FV antérieur n'indique pas un problème d'intégrité des données. Cela signifie simplement que les fichiers écrits après la date d'horodatage FV n'ont pas encore été vérifiés.
- Pour tout système exécutant la version DDOS concernée (également tout système récemment mis à niveau vers la version corrigée), si l'horodatage FV est antérieur de plus d'une semaine (ou ne peut pas être déterminé), contactez le support client Dell Technologies pour valider les données.
Article Properties
Article Number: 000200905
Article Type: Solution
Last Modified: 11 Dec 2023
Version: 10
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