PowerProtect VM Direct Engine state "Server Certificate does not match with any known certificates"
Summary: PowerProtect Data Manager is unable to check vProxy state with "Server Certificate does not match with any known certificates. Server's identity has changed"
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
The PowerProtect Data Manager Virtual Machine (VM) Direct Engine solution is used to protect the vSphere environment. The PowerProtect Interface Infrastructure Protection Engine page shows an error status for the my-vproxy.my-domain.com VM Direct Engine.
Unable to check vProxy 'my-vproxy.my-domain.com' state: Get "Https://my-vproxy.my-domain.com:9090/api/v1/VproxyEngines/RstEngine": Server Certificate does not match with any known certificates. Server's identiy has changed. (proxy: my-vproxy.my-domain.com)
Cause
The VM Direct Engine was moved to a new ESXi cluster managed by a different vCenter server. The certificate contains references to the deployment vCenter server, which would not be valid on the new vCenter server.
Resolution
Remove the existing VM Direct Engine and deploy it against the new ESX\vCenter environment.
- Open the PowerProtect Data Manager Interface.
- Navigate to "Infrastructure > Asset Source" and add the new vCenter server to the PowerProtect configuration.
- Navigate to "Infrastructure > Protection Engines" and capture the relevant networking details (IP Address, DNS, Gateway) for the affected vProxy.
- Delete the affected VM Direct Engine from the configuration.
- Add a new VM Direct Engine with the relevant networking details and select the new target vSphere resources.
- The new VM Direct Engine has a new certificate with the appropriate vCenter server details.
Article Properties
Article Number: 000205623
Article Type: Solution
Last Modified: 03 Dec 2025
Version: 2
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.