Data Protection Advisor: Data Domain systems are missing in the Data Domain Capacity Utilization report
Summary: Data Domain systems are missing in the Data Domain Capacity Utilization report.
Symptoms
All SNMP-based data collection requests for Data Domain systems missing in the Data Domain Capacity Utilization report failed with the following error message:
Either host is down or invalid credentials have been provided
All SSH-based data collection requests complete successfully. Within the debug low dpaagent.log, the SNMP requests a timeout attempting to collect information and then return the above error message:
DBG1 21920.22184 20200206:143435 agent.manager - agentManagerRunRequest(): Running request datadomain:status for target <DD_hostname> >> DBG2 21920.22184 20200206:143435 com.snmp - _aapiSNMPGetPDU(): attempting to get OID 1.3.6.1.4.1.19746.1.13.1.1.0 >> DBG2 21920.22184 20200206:165435 com.base.i18n - convertToUTF8Data(): convdata->conv is NULL DBG1 21920.22184 20200206:165435 com.snmp - _aapiSNMPGetPDU(): request timed out >> DBG2 21920.22184 20200206:165435 com.snmp - _aapiSNMPGetPDU(): attempting to get OID 1.3.6.1.2.1.1.1.0 >> DBG2 21920.22184 20200206:191435 com.base.i18n - convertToUTF8Data(): convdata->conv is NULL DBG1 21920.22184 20200206:191435 com.snmp - _aapiSNMPGetPDU(): request timed out DBG2 21920.22184 20200206:191435 com.base.i18n - convertToUTF8Data(): convdata->conv is NULL ERR 21920.22184 20200206:191435 agent.mod.dd - status_snmp(): Either host[<DD_hostname>] is down or invalid credentials has been provided >> DBG1 21920.22184 20200206:191435 agent.reporter - agentReportSend(): successfully sent report to server https://127.0.0.1:9002/dpa-api/agent/93616105-8123-4501-ab05-16c0cdfb595c/report DBG1 21920.22184 20200206:191435 agent.reqqueue - aapiReturnAgentRequest(): Request datadomain:status for target <DD_hostname>: will next run at 1581038975
The Data Domain system is configured with multiple NICs and IPs. When running nslookup from the DPA Agent against the Data Domain short name, it resolves to multiple IP addresses where only one of the IPs (a.b.c.130) is the management interface:
nslookup <DD_short_name> Server: <DNS_server_hostname> Address: <DNS_server_IP_address> Name: <DD_FQDN> Addresses: a.b.c.135 a.b.c.133 a.b.c.130 a.b.c.132 a.b.c.131 a.b.c.136 a.b.c.138 a.b.c.134 a.b.c.137
Running snmpwalk against the Data Domain hostname (is below) from the DPA agent fails.
snmpwalk.exe -r:<DD_hostaname> -c:public -v:2c -p:161
Running snmpwalk against the IP address of the management interface (a.b.c.130) completes successfully and returns data from the Data Domain.
Cause
The Data Domain system was configured to use multiple interfaces, but only the management interface accepts incoming SNMP requests.
Resolution
The following steps can be taken to resolve the issue:
- Log in to the DPA Agent system
- Browse to the hosts file (location depends on O/S)
- Open host file with a text editor
- Add or update entry for Data Domain hostname so the management interface IP is now listed
- Restart the DPA Agent services
Contact Dell Technical Support for further details or information.