PowerFlex: System Board NVDIMM Battery Unknown

Summary: User has one node in the system where the NVDIMM battery status reports as 'Unknown' but that is not one of the three options listed for the status.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

User has one node in the system where the NVDIMM battery status reports as 'Unknown' but that is not one of the three options listed in the Dell NVDIMM-N Persistent Memory User Guide for the NVDIMM battery status. The three options for the status are:

  • Present-Ready 
  • Present-Offline 
  • Not-Present
Screenshot of NVDIMM battery status in system
Figure 1: Screenshot of NVDIMM battery status in system

Cause

The following logs were requested and reviewed to investigate the NVDIMM battery issue:

  • TSR report with the 'Debug Logs' option selected. (For instructions on getting the report, see Dell article 126308, Export a SupportAssist Collection Using an iDRAC9)
  • VMsupport bundle (if applicable) of affected node 
  • SOS Report (if possible to install and use) 

After initial troubleshooting was performed (clear SEL, reset iDRAC, reboot, and so forth), a log showed in the TSR report advising of failed BIOS update jobs.

Screenshot of failed BIOS update job
Figure 2: 
Screenshot of failed BIOS update job

The node was running BIOS 2.9.4 whereas all the other nodes were running BIOS 2.16.1.

Screenshot showing BIOS version
Figure 3: Screenshot showing BIOS version

Resolution

To address the issue, the user was asked to update the BIOS of the node to the same version as the other nodes, update the BIOS from 2.9.x to 2.16.1: 
  1. Clear Job Queue using iDRAC UI (Maintenance > Job Queue > Delete All)
  2. Update BIOS to version 2.16.1
In this instance, the user was unable to update the BIOS as the process stopped at the step "scheduled state." A soft reboot and reset of the server did not resolve the suspended update. Doing a FLEA drain and DIMM replacement resolved the issue and allowed the BIOS to update to the required version.

Affected Products

Converged Infrastructure, Converged Systems, Solutions, PowerFlex Appliance, PowerFlex custom node

Products

VxFlex Ready Nodes
Article Properties
Article Number: 000218873
Article Type: Solution
Last Modified: 16 Sept 2025
Version:  3
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.