Network KVM PC Logout and Relogin Takes a Long Time to Auto-Reconnect
Summary: This article provides information about the network Keyboard/Video/Mouse (KVM) connection features of Dell Display and Peripheral Manager (DDPM) for macOS.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Dell Display and Peripheral Manager for macOS users might experience the network KVM taking 20-30 seconds to auto reconnect. This issue is seen after you log out or sign out the connected personal computer and re log-in or sign in again to the personal computer.
Cause
Computer takes time to restart the Network KVM service.
Resolution
Updating the DDPM to version 1.3.2.0015, A00 or later on the computer resolves the issue. To download and install the driver, reference How to Download and Install Dell Drivers.
Affected Products
Dell C2423H, Dell C5519QA, Dell 24 Video Conferencing Monitor C2422HE, Dell 27 Video Conferencing Monitor C2722DE, Dell 34 Video Conferencing Curved Monitor C3422WE, Dell C5522QT, Dell C6522QT, Dell C7520QT, Dell C8621QT
, Dell Display and Peripheral Manager, Dell P2424HEB, Dell P2425E, Dell P2425HE, Dell P2724DEB, Dell P2725HE, Dell P3424WEB, Dell 27 Plus 4K USB-C Monitor S2725QC, Dell 32 Plus 4K QD-OLED Monitor S3225QC, Dell 34 Plus USB-C Monitor S3425DW
...
Article Properties
Article Number: 000223598
Article Type: Solution
Last Modified: 15 Sept 2025
Version: 5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.