DPA: Job Monitor on NetWorker 9.0.1 is not working

Summary: This article explains the resolution when the Job Monitor on NetWorker 9.0.1 is not working.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

In NetWorker 9.0.1, the Job Monitor request is failing. Examining the modtest log it showed that the nsradmin commands are failing to run.
An example of nsradmin command and error is below.

nsradmin -s <Networker Server hostname>
. type: NSR
show type; version; hostname
print
quit
failed to write to child
child exited with status 1

When attempting to run the nsradmin command from NetWorker (without DPA), the error noticed was:

# cd /usr/sbin
# nsradmin -s <Networker Server hostname>
143820:nsradmin: Unable to establish RAP connection with <Networker Server hostname>  
 el: Unable to set user privileges based on user token for root on <Networker Server hostname>:
Security token has expired.

 

Cause

The NetWorker authentication token expired.

 

Resolution

The workaround is to run the nsrlogin command from NetWorker as below.

/usr/sbin # nsrlogin -u <administrator> -p <password>-
Authentication succeeded

After running nsrlogin, DPA can run nsradmin commands and get a successful Job Monitor collection.

Contact NetWorker Support for additional assistance to avoid this from recurring.

 

Affected Products

Data Protection Advisor
Article Properties
Article Number: 000054741
Article Type: Solution
Last Modified: 22 Dec 2025
Version:  5
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