PowerFlex: Cannot access Datastores

Summary: Possible reasons for the inability to access devices presented by ScaleIO.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Possible scenarios:

  • ESXi hosts cannot write or read to Datastores that are presented by PowerFlex
  • ESXi hosts cannot see devices that are being presented by PowerFlex
  • ESXi hosts hang when trying to create Datastores presented by PowerFlex

Cause

Possible causes:

ESXi/SDS networking is not configured correctly.

  • The ESXi host must have vmknic/s configured to reach the SDS backend data paths.
  • The SDS VM must have nic/s configured to reach the ESXi hosts frontend data paths.
  • If the PowerFlex backend has Jumbo frames enabled, then the ESXi hosts MUST be enabled as well.
  • Duplicate IPs may exist in the environment

To confirm the networking is configured correctly, do the following tests:

  • Ping from the ESXi host to each SDS data path/s: vmkping -d -s 8972 <x.x.x.x>
  • Ping from the SDS to the problem ESXi host/s on the data path/s: Ping -M do -s 8972 <x.x.x.x>
  • Run this command on the ESXi host to check the connection state to the SDSs: localcli network ip connection list
    • [root@localhost:~] localcli network ip connection list
      Proto  Recv Q  Send Q  Local Address                            Foreign Address      State        World ID  CC Algo  World Name
      -------------------------------------------------------------------------------------------------------------------------------
      tcp         0       0  10.0.1.1:58090                         10.0.1.1:7073     SYN_SENT        71052  newreno  net_sched
      tcp         0       0  10.0.1.2:58011                         10.0.1.2:7072     ESTABLISHED     71052  newreno  net_sched
      tcp         0       0  10.0.1.3:58094                         10.0.1.3:7072     ESTABLISHED     71052  newreno  net_sched
      		Note that the State "SYN_SENT" indicates a connection issue. The state to each SDS needs to be "ESTABLISHED"
      		 

Wrong SDS package installed.

  • The standard SDS package (EMC-ScaleIO-sds-2.0.x) operates on port 7072 while other SDS packages operate on other ports. 
    • Example: EMC-ScaleIO-sds1-2.0.x operates on port 7073.
  • The SDC package is defaulted to connect through port 7072.
  • To check which port the SDSs are operating on, run the following command from the current master MDM:
    • scli --query_all_sds |grep -i SDS
       
      • SDS ID: 78b9ea2900000002 Name: 10.0.0.3-ESX State: Connected, Joined IP: 10.0.1.3 Port: 7073 Version: 2.0.13000
        SDS ID: 78b9ea2800000001 Name: 10.0.0.2-ESX State: Connected, Joined IP: 10.0.1.2 Port: 7072 Version: 2.0.13000
        SDS ID: 78b9ea2700000000 Name: 10.0.0.1-ESX State: Connected, Joined IP: 10.0.1.1 Port: 7072 Version: 2.0.13000
        			


 
 

Resolution

  • Add any necessary vmknic/s to the ESXi host to ensure that it can reach communicate on the backend data paths.
  • Enable Jumbo frames throughout the entire Data network if Jumbo frames are being used.
  • Install the correct SDS package if the wrong one was installed unknowingly. 

Affected Products

VxFlex Product Family

Products

VxFlex Product Family
Article Properties
Article Number: 000056326
Article Type: Solution
Last Modified: 24 Nov 2025
Version:  4
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