Avamar: Hyper-V-sikkerhedskopieringer mislykkes med fejl om adgang nægtet

Summary: Avamar - Hyper-V-sikkerhedskopieringer mislykkes med fejl om adgang nægtet.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

I dette tilfælde oplever vi Hyper-V-sikkerhedskopieringsfejl, og sikkerhedskopieringslogfilerne viser fejlmeddelelserne "AccessDenied" i henhold til nedenstående eksempel:

From Hyper-V Plugin log:
================
avhypervvss Info <0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'
avhypervvss Info <0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))'
avhypervvss Info <0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                         Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))
avhypervvss Info <0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection :
                         Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

avhypervvss Error <41753>: Unable to get the clustered VMs for backup. 
avhypervvss Error <41731>: Failed to collect the list of local VMs on this host
avhypervvss Error <41581>: Failed to backup targets. Unable to expand targets.
avhypervvss Error <41662>: Failed to validate and expand the targets.
avhypervvss Error <41659>: Backup did not complete successfully


From cluster service log:
================
winclustersvc DEBUG<0000>: ===> QueryVmsFull 
winclustersvc INFO<0000>:  Get the basic info for the target VMs 
winclustersvc INFO<0000>:  Start getting the basic of the VMs 
winclustersvc DEBUG<0000>: Connect with namespace '\\xxxxxxxx\root\virtualization\v2' 
winclustersvc ERROR<0000>: Error in connecting with the namespace: Exception 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' 
winclustersvc ERROR<0000>: Failed to get the VM info: Excpetion 'GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))' 
winclustersvc ERROR<0000>: QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                           Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)) 
winclustersvc ERROR<0000>: Exception in GetClusterVMs GetClusterVMs : QueryVmsFull : QueryVmsBasic : QueryVmsBasic : GetWmiConnection : 
                           Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).

 

 

Cause

Disse typer fejl er selvforklarende. Disse fejl betyder, at brugerkontoen til Avamar-tjenesterne (lokal agent og klyngeagent) ikke har tilstrækkelige tilladelser til at køre WMI-forespørgslerne (Windows Management Instrumentation).

 

Du kan løse dette problem ved at give de korrekte tilladelser til den brugerkonto, der bruges til at køre Avamar-klienttjenesterne.

 

Resolution

Additional Information

Dette er også nævnt mere detaljeret i "Brugervejledning til Dell Avamar til Hyper-V". Se linket til vejledningen til version 19.10 eller en anden version på Avamar-supportsiden .

 

Affected Products

Avamar

Products

Avamar, Avamar Plug-in for Hyper-V VSS
Article Properties
Article Number: 000165638
Article Type: Solution
Last Modified: 10 Oct 2024
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.