Avamar: SharePoint backup error "Windows structured exception ACCESS_VIOLATION"
Summary: This knowledge base (KB) article provides a workaround for SharePoint backup failures due to simultaneous backups on backend servers.
Symptoms
SharePoint backups may fail or complete with exception errors similar to the following:
2014-04-29 20:13:27 avmossvss Error <0000>: The back-end client SQLBACKEND will be dropped later in the process.
2014-04-29 20:16:27 avmossvss Error <0000>: The back-end plug-in on client SQLBACKEND (10.1.1.1) terminated with errorcode 10019: Externally cancelled by Administrator.
2014-04-29 20:24:33 avmossvss Error <13968>: The back-end client [SQLBACKEND] has failed to backup, so its components will not be displayed for restore.
2014/04/30-01:24:38.88199 mossvss_ctl_sup DEBUG-ERROR <0378> threadimpl::runthread() - Windows structured exception ACCESS_VIOLATION in threadID 20148
Cause
SQL maintenance jobs on the backend database server either start simultaneously or overlap with the SharePoint backup on the frontend client. These conflicting backup jobs then cause either or both jobs to fail. Though the SharePoint backup starts on the frontend client, that frontend client sends a subworkorder to each backend client to back up the SharePoint databases. If another process locks the SharePoint databases, then the SharePoint plugin is unable to back up the databases on the backend client.
The backend clients in the SharePoint farm being registered to a different Avamar grid than the frontend client can also lead to similar errors.
Resolution
Rearrange the scheduled jobs for either the SQL maintenance or Avamar SharePoint backup to a different time range, so that they do not overlap.
If the servers in the SharePoint farm are registered to different Avamar grids, re-register all of them to the same Avamar grid. For federated backups (SharePoint, Exchange, SQL AlwaysOn), registering the Windows clients to different Avamar grids is not a supported configuration.