PowerProtect Data Manager: Users are unable to authenticate using active directory credentials when users are part of nested groups.

Summary: Users from nested active directory groups are unable to log in to PowerProtect Data Manager.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Active directory (AD) environment has groups as members within groups. Parent groups have been mapped within PowerProtect Data Manager (PPDM) for various roles. Only users which have been added directly to the parent groups can log in and perform the roles assigned. Members of the subgroups are unable to log in.

Example:
Top-level group assigned to the administration role: GroupA

GroupA has the following added under "Members":
GroupB (member: UserB)
GroupC (member: UserC)
UserD

Only UserD can log in and perform administrative functions. UserB and UserC which are members of GroupB or GroupC are unable to log in.

Cause

The product is working as per its current design on the time of writing this article. The latest version available for PowerProtect Data Manager is 19.20.

Resolution

PowerProtect Data Manager only allows direct users from the groups added to PPDM. Groups which contain the users to whom permissions are to be assigned, should be added to PPDM.

Request for enhancement (RFE PPAS-I-1085) has been submitted for product management for review. If you are experiencing the same issue and would like your site to be associated with the RFE, contact DELL technical support and reference this article.

Affected Products

PowerProtect Data Manager, PowerProtect Data Manager Essentials
Article Properties
Article Number: 000223442
Article Type: Solution
Last Modified: 02 Sept 2025
Version:  2
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