PowerEdge: "Invalid Value" Error when Setting Up Password Via iDRAC UI

Summary: Setting the setup password using iDRAC User Interface (UI) results in an 'Invalid value' error

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

The issue is seen when trying to set the setup password using the iDRAC UI.

It is characterized by an 'Invalid value' error, which occurs even when attempting to set the password.

The error persists despite trying:

  1. Different keyboards
  2. Using the virtual keyboard from the virtual console
  3. Updating the iDRAC

However, setting up the password using the BIOS directly works and the issue does not appear.

Cause

The issue is due to old firmware.

Resolution

The issue is resolved when updating the BIOS to version 2.6.3, which is in the fixes and enhancements on the support page. 

 

Affected Products

OEMR R660, OEMR R660xs, OEMR R760, OEMR R760xa, OEMR R760XD2, OEMR R760xs, OEMR R860, OEMR R960, PowerEdge R660, PowerEdge R660xs, PowerEdge R760, PowerEdge R760XA, PowerEdge R760xd2, PowerEdge R760xs, PowerEdge R860, PowerEdge R960
Article Properties
Article Number: 000347852
Article Type: Solution
Last Modified: 21 Jul 2025
Version:  1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.