PowerProtect Data Manager Discovery Fails Against SQL Server with ASDS0027 Error
Summary: PowerProtect Data Manager discovery fails against SQL server with ASDS0027 error.
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
When attempting to perform a discovery against a Microsoft SQL Server, the discovery job may fail with the following error:
ASDS0027:
Discovery of all application systems for addon MICROSOFT_SQL_DATABASE_SYSTEM is unsuccessful on host <SQL Server Host> because of the following errors:
General exception when detecting AAG information for SQL Server '<SQL Server Host>'. .
The application system discovery is unsuccessful.
Check the log files at the following locations for more information:
On Windows: INSTALL_DIR\DPSAPPS\AGENTSERVICE\logs.
On Linux or AIX: /opt/dpsapps/agentsvc/logs.
Cause
The PowerProtect Data Manager service runs under the local system account. By default, discovery of SQL assets is performed using the Local System account against the Microsoft SQL Server.
The discovery failure occurs because the NT Authority\SYSTEM account is not a member of the SYSADMIN security role in SQL.
Resolution
To address the issue, add the NT Authority\SYSTEM account to the SYSADMIN security role on the Microsoft SQL Server instance. If this is not possible, you can have PowerProtect Data Manager use a different account to perform discoveries and backups.
To configure this setting, follow these steps:
- In the PowerProtect Data Manager Admin UI, go to Infrastructure\Asset Source and select the SQL tab.
- Select the checkbox next to the SQL Server from the list and select Edit Credentials
- In the Credentials list, select the account that you want to perform backups and discoveries against the SQL server. This account must be a Local Admin on the Windows Server and be a member of the SYSADMIN security group on the SQL instance.
Note: This setting overrides the backup account configuration that is set in the Protection Policy that the SQL server is assigned to.
Affected Products
PowerProtect Data ManagerArticle Properties
Article Number: 000376248
Article Type: Solution
Last Modified: 01 Oct 2025
Version: 1
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.