In de Avamar UI Events-tabel worden kernelfouten weergegeven die betrekking hebben op de startbewerking van ConnectEMC

Summary: Dit artikel bevat de oplossing van wanneer de Avamar UI kernelfouten weergeeft met betrekking tot het starten van ConnectEMC.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Nadat een gebruiker 2021 R3 OS Security Rollup heeft geïnstalleerd op Avamar-servers met versie 19.3 en hoger met SLES12SP5 besturingssysteem, geeft de Avamar UI kernelfouten weer met betrekking tot het starten van ConnectEMC in de tabel Gebeurtenissen. Dit gebeurt als e-mailinstellingen niet zijn geconfigureerd in het apparaat.

In de avamar UI-gebeurtenissentabel worden opstartfouten van ConnectEMC weergegeven, zoals:

kernel: [86242.549021] traps: connectemc[15298] general protection ip:f762cae7 sp:ffdd6b54 error:0 in libstdc++.so.6.0.29

 

Cause

Na een gebruikersupgrade naar apparaatversie 2.7.2 hebben de Avamar serverknooppunten SLES12 SP5 met de 2021 R3 OS Security Rollup geïnstalleerd. Als gevolg van de bijgewerkte binaire bestanden van het besturingssysteem, ondervindt ConnectEMC een opstartprobleem als de /opt/connectemc/ConnectEMC_config.xml configuratiebestand lege waarden of zelfs lege spaties heeft voor de EmailSender als EmailServer Parameters.
Bijvoorbeeld, in het voorbeeldbestand hieronder, EmailSender als EmailServer zijn niet geconfigureerd met waarden, bovendien heeft het een lege ruimte.

 

cat /opt/connectemc/ConnectEMC_config.xml
<?xml version="1.0" encoding="UTF-8" standalone="no" ?>
<ConnectEMCConfig SchemaVersion="1.1.0">

  <ConnectConfig Type="Email">
    <Retries>5</Retries>
    <Notification>Primary</Notification>
    <Timeout>300</Timeout>
    <Description>Avamar ConnectEMC Notification Email</Description>
    <BsafeEncrypt>yes</BsafeEncrypt>
    <IPProtocol>IPV4</IPProtocol>
    <EmailServer> </EmailServer>
    <EmailAddress>emailalert@emc.com</EmailAddress>
    <EmailSender> </EmailSender>
    <EmailFormat>ASCII</EmailFormat>
    <EmailSubject>Avamar ConnectEMC Notification Email</EmailSubject>
    <STARTTLS>no</STARTTLS>
    <IncludeCallHomeData>no</IncludeCallHomeData>

 

Als de instellingen voor e-mailmeldingen niet op het apparaat zijn geconfigureerd, is de EmailServer als EmailSender velden in de ConnectEMC_config.xml configuratiebestand op de Avamar server is geconfigureerd met enkele lege spaties voor beide velden.

 

Resolution

Configureer de Connectemc-configuratie door de Avamar-beheerhandleiding te volgen OF handmatig de ConnectEMC_config.xml configuratiebestand (leeg het configuratiebestand) op de Avamar-server.

 

  1. Configureer instellingen voor e-mailmeldingen door de Avamar-beheerhandleiding te volgen

Volg de gedetailleerde stappen die worden beschreven in hoofdstuk met de naam "Server Monitoring" onder sectie "ConnectEMC".

 

  1. Stappen om de configuratie nul uit te stellen (het configuratiebestand leegmaken):

Als u geen e-mailmeldingen wilt configureren, moet u handmatig de ConnectEMC_config.xml configuratiebestand (leeg het configuratiebestand) op de Avamar server met behulp van de onderstaande stappen:

  1. Maak verbinding met Avamar met behulp van SSH met een beheerdersaccount.
  2. Schakel over naar het root-gebruikersaccount.
  3. Wijzig de naam van het huidige configuratiebestand.
mv /opt/connectemc/ConnectEMC_config.xml /opt/connectemc/ConnectEMC_config.xml.orig

 

  1. Maak het configuratiebestand zonder waarden.
touch /opt/connectemc/ConnectEMC_config.xml

 

  1. Controleer of het configuratiebestand leeg is.
ls -latr /opt/connectemc/ConnectEMC_config.xml
-rw-rw-r-- 1 root admin 0 Feb  7 22:36 ConnectEMC_config.xml

 

  1. Start de ConnectEMC-service opnieuw op met behulp van de volgende opdrachten:
service connectemc stop
service connectemc start

 

Affected Products

Avamar, Avamar Server
Article Properties
Article Number: 000198174
Article Type: Solution
Last Modified: 10 Feb 2025
Version:  8
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.