VNX : remplacement (proactif ou non) d’un disque Vault en panne ou défectueux sur une baie VNX2. (Corrigible par Dell EMC)

Summary: remplacement (proactif ou non) d’un disque Vault en panne ou défectueux sur une baie VNX2.

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Symptoms

Émettre:
Un disque de coffre-fort sur une baie VNX MCx est défaillant et a été épargné vers un autre emplacement.  Si le client avait créé des LUN utilisateur sur les disques Vault et souhaite redéplacer ces données sur le disque Vault, comment procéder ? 

Le remplacement permanent n’entraîne aucune opération automatique de répartition de la reconstruction.  Si un disque standard est remplacé suite à sa défaillance, le remplacement permanent sur le nouveau disque n’entraîne aucune opération automatique de répartition.  Le disque qui a remplacé le disque défaillant fait désormais partie du groupe RAID.

Lorsqu’un disque Vault défaillant est remplacé, le nouveau disque est formaté et l’espace privé est reconstruit à partir des autres disques Vault. Toutefois, si un client a créé un groupe RAID ou des LUN sur un disque Vault, les données LUN ne sont pas copiées.  Elles restent sur le disque sur lequel elles ont été reconstruites.  Pour copier manuellement les données vers leur emplacement d’origine, vous devez utiliser la commande naviseccli copytodisk.  

Info:
Les disques vault sur VNX2 de nouvelle génération sont les 4 premiers disques de la baie. 0_0, 0_1, 0_2 et 0_3.  
Chaque disque Vault nécessite environ 300 Go d’espace système privé pour contenir le code MCx et les autres données relatives à la baie. 

Bien que ce ne soit pas recommandé, certains clients placent des LUN sur les disques Vault. 

Cause

VNX nouvelle génération ne répartit ni ne reconstruit les données client qui ont été créées sur des disques Vault.  Lorsqu’un disque Vault est remplacé, le nouveau disque est formaté et l’espace privé est reconstruit à partir d’autres disques Vault, mais les données LUN client ne sont pas copiées. Pour copier manuellement les données dans leur emplacement d’origine, vous devez utiliser la commande naviseccli copytodisk.

Resolution

Scénario 1 :  Le disque Vault est en panne et a déjà été définitivement mis en réserve sur un autre disque de la baie.  Pour répartir les données du client dans leur emplacement Vault d’origine, procédez comme suit :
La commande naviseccli copytodisk lance la copie des données depuis un disque configuré (qui fait partie d’un groupe RAID) vers un disque non lié. L’utilisateur peut utiliser cette commande pour copier les données de n’importe quel disque lié vers n’importe quel disque non lié, et pas seulement d’un disque de secours permanent vers un disque de remplacement.
Dans cet exemple, nous copions les données du disque 0_1_5 vers le disque 0_0_2

naviseccli -h <ipaddress> copytodisk 0_1_5 0_0_2
WARNING : Les données du disque source 0_1_5 seront copiées vers le disque de destination 0_0_2. Ce processus ne peut pas être interrompu et peut prendre beaucoup de temps.

Voulez-vous poursuivre la copie ? (o/n) o

L’opération de copie se lance.

Scénario 2 : Des messages indiquent que le disque est en panne.  Comment remplacer de manière proactive le disque Vault en panne dans les logements 0, 1, 2 et 3 sur le bus 0 ?

  1.  Veillez à retirer tous les disques non liés de la baie. (Nous recommandons cela, car tout disque non lié peut devenir un disque de secours (hotspare) permanent sur la baie VNX2.)
  2. Vérifiez les disques dans les emplacements de logement 0, 1, 2 et 3 via Unisphere ou Naviseccli. Avant de continuer, assurez-vous qu’il n’y a pas de panne en double sur cet ensemble de disques. 
  3. Une fois le délai de 5 minutes écoulé, insérez le nouveau disque dans le logement. Le disque doit être retiré pendant au moins 5 minutes pour que la reconstruction des LUN du client se termine sur le disque Vault. Patientez au moins 5 minutes**3  Retirez le disque en panne ou le disque suspect qui doit être remplacé du logement et
  4.  Le nouveau disque sera mis en ligne et reconstruira les LUN de ses utilisateurs (si les LUN de ses utilisateurs ont été configurées sur les disques Vault) démarrera à partir des autres disques Vault.


Remarque ** Il est très important de laisser le disque retiré pendant au moins 5 minutes
Flare permet à un disque d’un groupe RAID redondant d’être hors ligne pendant une période allant jusqu’à 5 minutes pendant que les E/S d’écriture sur ce disque sont consignées. Les E/S réelles ne sont pas consignées. Une image bitmap sert à assurer le suivi des plages d’adresses qui sont sales sur le disque. Si le même disque redevient accessible dans les 5 minutes, le journal de reconstruction est utilisé pour réaliser une reconstruction rapide du disque, comme dans le cas présent. C’est ce qu’on appelle une reconstruction différentielle. Une fois que le disque a été retiré pendant plus de 5 minutes, une reconstruction complète des LUN des autres disques Vault se produit.  Si aucune LUN utilisateur n’est configurée sur les disques Vault, il n’est pas nécessaire de reconstruire les LUN utilisateur.

Affected Products

VNX2 Series

Products

VNX5200
Article Properties
Article Number: 000029126
Article Type: Solution
Last Modified: 17 Jun 2025
Version:  4
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