Avamar: SQL backups fail with "Login failed for user"

Summary: SQL backups fail with "Login failed for user" message with multiple SQL server authentication instances.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Avamar SQL backups may fail with errors similar to the following:
 

avsql Error <40258>: sqlconnectimpl_smo::connect Microsoft.SqlServer.Management.Common.ConnectionFailureException: Failed to connect to server DELLSVR\SQLINSTANCE. ---> System.Data.SqlClient.SqlException: Login failed for user 'backupuser'.

Cause

The dataset designated for SQL backups is using SQL Server authentication rather than Windows authentication.

There are multiple SQL instances on the client. One or more of the SQL instances may not have granted security access to the SQL Server login account.

Resolution

Workarounds to resolve the issue:

  1. Add the SQL Server login account to the instances in SQL Server Management Studio (SSMS) and grant the sysadmin role to it.
  2. Edit the dataset and exclude the SQL instances that have not allowed SQL Server login account access.
  3. Verify that the SQL login account is not disabled in SSMS.
  4. Reset the password for the SQL login account if it has expired.
  5. Ensure that the SQL login account has access to the database.

Affected Products

Avamar

Products

Avamar
Article Properties
Article Number: 000034616
Article Type: Solution
Last Modified: 28 Nov 2025
Version:  6
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.