Avamar:サーバーのタイムアウトの問題によりファイル システムのバックアップが失敗する

Summary: 接続またはタイムアウトの問題によるAvamarバックアップの失敗に対処するナレッジベース(KB)記事。

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Symptoms

Windowsクライアントのファイル システム バックアップが失敗し、ログに次のエラーと致命的なメッセージが表示されることがあります。

2012/12/28-21:59:34.82899 [ade-async]  ERROR: <0001> Message timed out (could not be sent), id=xxx count=0 delay=14105.7"
...
2012-12-29 02:29:34 avtar Error <5774>: Internal Error: backtree: ADD_HASH timeout error

2012-12-29 02:29:34 avtar Stats <15102>: 2012-12-29 02:29:34 COMSTATS:0 sent=   8 recv[0]=  12  pending=  7/175 int= 0/50 send= 82 bytes=  1120+  209192 sleepms= 0 delay=(16.457 [15.056..19.919] sd=1.946 n=  11) (15.461 [15.461..15.461] sd=0.000 n=   1)
2012-12-29 02:29:34 avtar Info <5726>: Aborting backup due to error (1:EXC_TIMEOUT)
2012/12/28-21:59:34.95399 [avtar]  nbackmain connection exception 1 EXC_TIMEOUT
2012-12-29 02:29:34 avtar FATAL <5397>: Server timeout: Communication failure with server, aborting.  Correct network connectivity issues, verify access to the server and retry. "
...
<ERROR>Message exceeded retry count in retry.cpp 25415 count=16 </ERROR> 

 

Cause

この問題が発生する原因はいくつか考えられます。

  • Windowsクライアントで、ネットワーク レイテンシーが異常に高かったり不規則であったり、接続の問題が発生したりすることがあります。

  • Avamarグリッドとクライアント間の時刻同期の問題。

Resolution

avtar.cmdファイルを編集または作成し、次のフラグを追加して、バックアップを再試行します。

--debug
--comstats
--stats
--conntimeout=2800
--readonly-retry-timeout=4500
--msg-retry-timeout=300
 

Avamarグリッドでプロアクティブなヘルス チェックを実行し、ネットワーク構成やIPアドレスの重複に関する問題がないことを確認します
KB記事「 Avamar: プロアクティブ ヘルス チェック スクリプトを実行する方法については、「Avamarサーバーでproactive_check.plヘルス チェック スクリプトを実行する方法」を参照してください。

グリッドでネットワーク構成の問題が検出されない場合、または上記のフラグを使用しても問題が解決しない場合は、ネットワーク環境が原因です。これには、異常に高いネットワーク レイテンシ、Quality of Service(QoS)設定の問題、クライアントとグリッド間のどこかでのデュプレックスの不一致の問題などが含まれる場合があります。

Additional Information

接続タイムアウト パラメーターにより、クライアント バックアップがタイムアウトする前に再試行する時間が長くなります。値は秒単位です。

readonly-retry-timeoutパラメーターは、Avamarグリッドが読み取り専用モードのときに、avtarがタイムアウトするまでに接続を再試行する秒数を示します

msg-retry-timeout パラメータは再試行タイムアウトを延長するため、サーバがビジー状態のときにクライアントが同じハッシュに対して送信する HASH_IS_PRESENT メッセージが少なくなります。これらのメッセージを表示するには、デバッグを有効にする必要があります。

Affected Products

Avamar, Avamar Client for Windows
Article Properties
Article Number: 000039333
Article Type: Solution
Last Modified: 08 Jul 2025
Version:  4
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