Avamar:由于服务器超时问题,文件系统备份失败
Summary: 解决由于连接或超时问题导致的 Avamar 备份失败的知识库 (KB) 文章。
This article applies to
This article does not apply to
This article is not tied to any specific product.
Not all product versions are identified in this article.
Symptoms
Windows 客户端的文件系统备份可能会失败,并在日志中显示以下错误和致命消息:
2012/12/28-21:59:34.82899 [ade-async] ERROR: <0001> Message timed out (could not be sent), id=xxx count=0 delay=14105.7"
...
2012-12-29 02:29:34 avtar Error <5774>: Internal Error: backtree: ADD_HASH timeout error
2012-12-29 02:29:34 avtar Stats <15102>: 2012-12-29 02:29:34 COMSTATS:0 sent= 8 recv[0]= 12 pending= 7/175 int= 0/50 send= 82 bytes= 1120+ 209192 sleepms= 0 delay=(16.457 [15.056..19.919] sd=1.946 n= 11) (15.461 [15.461..15.461] sd=0.000 n= 1)
2012-12-29 02:29:34 avtar Info <5726>: Aborting backup due to error (1:EXC_TIMEOUT)
2012/12/28-21:59:34.95399 [avtar] nbackmain connection exception 1 EXC_TIMEOUT
2012-12-29 02:29:34 avtar FATAL <5397>: Server timeout: Communication failure with server, aborting. Correct network connectivity issues, verify access to the server and retry. "
...
<ERROR>Message exceeded retry count in retry.cpp 25415 count=16 </ERROR>
Cause
多个根本原因可能会导致此问题发生:
-
Windows 客户端可能会遇到异常高或异常的网络延迟或连接问题。
-
Avamar 网格与客户端之间的时间同步问题。
Resolution
编辑或创建avtar.cmd文件,添加以下标记,然后重试备份:
--debug
--comstats
--stats
--conntimeout=2800
--readonly-retry-timeout=4500
--msg-retry-timeout=300
在 Avamar 网格上运行主动运行状况检查,以验证是否不存在网络配置或重复的 IP 地址问题。
请参阅知识库文章 Avamar:如何在 Avamar Server 上运行proactive_check.pl运行状况检查脚本 ,了解有关如何运行主动运行状况检查脚本的指导。
如果在网格上未检测到网络配置问题,或者上述标记无法解决问题,则是网络环境问题。它可能包括异常高的网络延迟、服务质量 (QoS) 配置问题、客户端和网格之间的双工不匹配问题等。
Additional Information
连接超时参数为客户端备份提供了更多时间,以便在超时之前重试。值以秒为单位。
readonly-retry-timeout参数指示在 Avamar 网格处于只读模式时 avtar 在超时之前重试连接的秒数。
msg-retry-timeout 参数延长了重试超时,因此当服务器繁忙时,客户端为同一哈希发送的HASH_IS_PRESENT消息更少。必须启用调试才能看到这些消息。
Affected Products
Avamar, Avamar Client for WindowsArticle Properties
Article Number: 000039333
Article Type: Solution
Last Modified: 08 Jul 2025
Version: 4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.