Data Protection Central lists Data Domains as Not Reporting after certificates are changed

Summary: Data Protection Central lists Data Domains as Not Reporting after Data Domain certificates are changed.

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Symptoms

Data Protection Central lists Data Domains as Not Reporting after Data Domain certificates are changed.

The following message displays in the /var/log/dpc/monitor/monitor.log:

2019-01-04 15:45:00,023 INFO dataDomainSystemInfoThread2 c.e.b.r.m.d.d.DataDomainInfoService Obtaining system info for Data Domain server <ddhostname>
2019-01-04 15:45:00,165 INFO dataDomainSystemInfoThread2 c.e.b.r.m.d.d.DataDomainInfoService Obtaining system info for Data Domain server <ddhostname>
2019-01-04 15:45:00,168 ERROR dataDomainSystemInfoThread2 c.e.b.r.m.u.SecureStorageCredentialsAccessor Unable to determine credentials for server <ddhostname>. Error: null
java.lang.NullPointerException: null

Cause

After Data Domain certificates are updated, Data Protection Central (DPC) fails to gather reporting data.

Once Data Domain is re-registered with DPC, the certificates may appear synchronized while the reporting still fails.

Resolution

1. Verify the thumbprints of certificates imported from Data Domain to DPC match the certificate thumbprints on Data Domain itself.

System Management > Select Data Domain > Edit System > Certificate Verification.

Example of matching certificates: 

1st certificate:
Issued to CN=<ddhostname>,OU=Root CA,O=Valued Datadomain Customer,L=<Location>,ST=CA,C=US
Issued by CN=<ddhostname>,OU=Root CA,O=Valued Datadomain Customer,L=<Location>,ST=CA,C=US
Thumbprint xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx58bbf1

2nd certificate:
Issued to CN=<ddhostname>,O=Valued DataDomain customer,OU=Host Certificate,ST=CA,C=US
Issued by CN=<ddhostname>,OU=Root CA,O=Valued Datadomain Customer,L=<Location>,ST=CA,C=US
Thumbprint xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx35cc63

On Data Domain CLI:
sysadmin@ddhostname# adminaccess certificate show
Subject                            Type                   Application          Valid From                          Valid Until                           Fingerprint                                     
-------------------------   ------------------   --------------------   ----------------------------------   --------------------------------   -----------------------__________
ddhostname                  host                     https             Wed Jun 21 06:25:08 2017   Sat Jun 13 13:25:08 2048   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:35:CC:63
ddhostname                   ca                        trusted-ca    Mon Jan 11 13:43:04 2016   Thu Jan  3 13:43:04 2047   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:58:BB:F1
ddhostname                   imported-host  ddboost       Tue Feb 14 14:28:38 2017   Sun Feb 13 14:28:38 2022   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
ddhostname                   imported-ca      ddboost       Fri Jan 27 13:26:34 2017   Mon Jan 25 13:26:34 2027   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
avamarhostname          imported-ca      ddboost       Tue Feb 14 13:55:40 2017   Sun Feb 13 13:55:40 2022   XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX:XX
-------------------------   -------------   --------------------   ------------------------   ------------------------   -------------------------



2. If the certificate thumbprints do not already match, remove and re-register the Data Domains to DPC. 

After re-registration, verify the certificate thumbprints on DPC now match those on the Data Domain.

3. If the "Not Reporting" symptom persists after certificates are confirmed to match, force a DPC update.

  • Go to System Management > Edit System > Certificate Verification in the user interface (UI). 
  • Select 'Save' if possible. If 'Save' is unable to be selected, select 'Cancel'.


With certificates now synchronized, return to the Data Domain Health Summary in the DPC UI and confirm that the Data Domain is now reporting.

Contact Dell Support for more information about this issue.

Affected Products

Data Protection Central

Products

Data Protection Central
Article Properties
Article Number: 000040911
Article Type: Solution
Last Modified: 29 Jul 2025
Version:  4
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