Dell Unity: Datenspeicher voll: Die Nutzung des VMware ESXI-Datenspeichers stimmt nicht mit der Nutzung des Unity-Pools überein
Summary: Dell Unity: Datenspeicher voll :: Die Nutzung des VMware ESXI-Datenspeichers stimmt nicht mit der Nutzung des Unity-Pools überein (vom Nutzer korrigierbar)
Symptoms
Die Datenspeichernutzung stimmt nicht mit der Nutzung des Unity-Pools überein.
Der Datenspeicher ist nahezu 100 % oder zu 100 % voll, was zu einer Nichtverfügbarkeit von Daten führt.
Der Datenspeicher wird über Unity per Thin Provisioning bereitgestellt.
Die erwartete Produktionsnutzung berücksichtigt nicht den vollen Datenspeicher.
Cause
Auf dem Host wird ESXi 5.5 Update 1a ausgeführt 1746018 2014-04-19 (Möglicherweise kann dies auch bei anderen ESXi-Versionen von 5.5 bis 6.5 auftreten, bestätigen Sie dies mit dem VMware-Support)
Liste der ESXi-Versionen https://kb.vmware.com/s/article/2143832
Da der nutzbare Speicherplatz nicht mit VMware und Unity übereinstimmt, sollte die Funktion zur Rückgewinnung von Nullspeicherplatz von VMware aus untersucht werden. Informationen zur Rückgewinnung von Speicherplatz in ESXi 5.5 finden Sie im folgenden VMware KB-Artikel:
https://kb.vmware.com/s/article/2057513
Mit vSphere 5.5 wurde ein neuer Befehl im esxcli-Namespace eingeführt, mit dem gelöschte Blöcke auf Thin Provisioning-LUNs zurückgewonnen werden können, die das VAAI-UNMAP-Primitiv unterstützen. In diesem Fall hat der ESXi-Host die gelöschten Blöcke nicht zurückgewonnen und somit den Datenspeicher gefüllt.
Resolution
Einbinden von VMware, Zitieren des VMware-Wissensdatenbank-Artikels 2057513 (https://kb.vmware.com/s/article/2057513)
Führen Sie eine Rückgewinnung von null Speicherplatz vom ESXi-Host aus. Dies kann die Auslastung des Datenspeichers verringern.