DD System Manager UI Tomcat: Risoluzione dell'errore: MSG-PMON-00012: Impossibile riavviare

Summary: Questo articolo della Knowledge Base descrive in modo più dettagliato l'errore di avviso di comando: MSG-PMON-00012: Impossibile riavviare /ddr/bin/sm_em. Impostazione dello stato su FAILED, che può essere generato nelle versioni DDOS 6.0 E 6.1. ...

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Symptoms

Questione

Problema di accesso all'interfaccia utente di System Manager o viene visualizzato il seguente avviso:
ddr_procmon: ALERT: MSG-PMON-00012: Cannot restart /ddr/bin/sm_em. Setting state to FAILED.

L'avviso può essere visualizzato sulla console stessa e in messages.engineering.
Non verranno visualizzati avvisi in #alerts show current

Nota: Questo avviso è stato visualizzato anche con DDVE

L'avviso procmon viene visualizzato comunemente;

  • Dopo l'aggiornamento di DDOS
  • Dopo un riavvio del sistema
  • Dopo aver riavviato i servizi web http, ad esempio, adminaccess enable http
  • Dopo l'esecuzione di altri comandi adminaccess

Cause

Il compito di Procmon è quello di riavviare un processo, se non è riuscito/è uscito. E se un processo continua ripetutamente a fallire, procmon lancia un avviso al riguardo.

Versioni precedenti:
Procmon è stato configurato per monitorare il processo di sm_em. Quando sm_em muore, procmon lo riavvia.
sm_em internamente avvia Apache in linea sm_em continua ad attendere in questa riga, fino a quando Apache non è in esecuzione. Se Apache si chiude per qualsiasi motivo, sm_em va avanti ed esce. Procmon sta monitorando sm_em, si riavvia sm_em e di conseguenza Apache viene riavviato da sm_em.

Ciò che è cambiato nell'ultima versione:
sm_em è l'avvio di Apache in background. Pertanto, non interrompe l'esecuzione di sm_em. sm_em va avanti e si ferma.
Procmon sta ancora monitorando sm_em. Riavvia sm_em e genera un avviso quando sm_em continua a uscire ogni volta.

Resolution

Soluzione alternativa

Il riavvio del servizio web del sistema, disabilitandolo e riabilitandolo utilizzando i seguenti comandi su DD CLI o Putty, può visualizzare l'interfaccia utente se non è accessibile, ma non sopprime gli avvisi:

ddr## adminaccess disable http
ddr## adminaccess disable https
ddr## adminaccess enable http
ddr## adminaccess enable https

I comandi precedenti dovrebbero riavviare i servizi Tomcat. Aprire l'interfaccia utente di DD System Manager per esaminare lo stato. 

Se il problema persiste, contattare il supporto Dell e fare riferimento a questo articolo. 

 

Risoluzione

Eseguire l'aggiornamento alla versione più recente di DDOS per le correzioni

Affected Products

Data Domain

Products

Data Domain, Data Domain Boost
Article Properties
Article Number: 000052791
Article Type: Solution
Last Modified: 06 May 2025
Version:  3
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