VxRail: L'host ESXi non risponde in vCenter e il problema si ripresenta dopo il riavvio dell host per diversi giorni

Summary: iSM ha esito negativo con errore TLS se iDRAC9 viene aggiornato alla versione 3.30.30 durante o dopo l'aggiornamento di iSM 3.4.

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Symptoms

Può succedere che alcuni host ESXi non rispondano in vCenter. Il riavvio dell'host potrebbe risolvere temporaneamente il problema, tuttavia, dopo diversi giorni, il problema si ripresenta. Questo problema si verifica solo sui server Dell PowerEdge 14G con iDRAC9.

Nel registro TSR, un messaggio del tipo:

2019-06-04 15:26:05 ISM0049 The iDRAC Service Module (iSM) is unable to communicate to the iDRAC because the client certificate is either unavailable or invalid.

Nel vmkernel.log,

2019-06-04T02:05:56.920Z cpu61:2105520)WARNING: VisorFSObj: 1576: Cannot create file /etc/cim/dell/srvadmin/iSM/ini/tttttttttttttyZxIL9 for process sfcb-dcism because the inode table of its ramdisk (etc) is full.

Nel hostd.log,

2019-06-02T13:39:59.688Z error hostd[2105490] [Originator@6876 sub=Libs opID=e4a0107a-853b-11e9-f2a3 user=dcui:vsanmgmtd] VsanUtil: Failed to lock esx.conf /etc/vmware/esx.conf.LOCK.2104629: symlink failed: No space left on device

Nell'interfaccia utente di iDRAC,
UI di iDRAC che mostra iSM non riusciti

 

Cause

iDRAC9 v3.30.30 ha introdotto un requisito obbligatorio per la creazione di un canale TLS sicuro con iSM v3.4.0-1471 o versione successiva.

Dell Engineering ha identificato uno scenario in cui si verifica una perdita di memoria se iDRAC9 non ha ancora negoziato questa connessione TLS protetta se iSM v3.4.0-1471 è stato installato o aggiornato prima dell'upgrade del firmware iDRAC. La perdita alla fine causa anche la perdita del numero di inode del kernel a causa di una marea di file INI temporanei creati in /etc/dell.

Le release software VxRail 4.5.400, 4.7.200 e successive integrano iSM v3.4.0-1471. Nelle versioni 4.5.400 e 4.7.212 è stata aggiunta una soluzione alternativa per prevenire questo problema. La versione 4.7.210 non è interessata dal fatto che si tratta di una versione solo di produzione, pertanto non sono disponibili aggiornamenti. Pertanto, è molto probabile che le release VxRail 4.7.200 e 4.7.211 riscontrino questo problema.

Nota: È anche possibile riscontrare questo problema se la scheda di sistema è stata sostituita a causa di un guasto hardware. Ciò si applica ai nodi che eseguono la versione 4.7.2xx [inclusa la versione 4.7.212 e il codice futuro]

 

Resolution

Riavviare l'host ESXi se non risponde già in vCenter.

La reinstallazione di iSM può attivare la rinegoziazione del canale TLS sicuro con iDRAC9 e risolvere il problema.

Sugli host ESXi interessati, eseguire i seguenti comandi per reinstallare iSM.

esxcli software vib remove -n dcism
esxcli software vib install -d <path to iSM VIB>

Se non è disponibile alcun inode in ESXi, è possibile rimuovere prima i file non necessari perché questo problema può anche causare l'esaurimento dell'inode.

ls -l /etc/cim/dell/srvadmin/iSM/ini/
rm -f /etc/cim/dell/srvadmin/iSM/ini/tttttt*

Se la scheda di sistema è stata sostituita a causa di un guasto hardware, si applicano anche i passaggi di risoluzione descritti sopra.

 

Affected Products

VxRail Appliance Series

Products

VxRail Appliance Series
Article Properties
Article Number: 000060464
Article Type: Solution
Last Modified: 29 Nov 2024
Version:  4
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