VxRail: Host ESXi jest wyświetlany jako niereagujący w vCenter, a problem pojawia się ponownie po ponownym uruchomieniu hosta przez kilka dni

Summary: Awaria iSM z błędem TLS, jeśli kontroler iDRAC9 zostanie uaktualniony do wersji 3.30.30 podczas aktualizacji iSM 3.4 lub po jej zakończeniu.

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Może się zdarzyć, że niektóre hosty ESXi pokażą się w vCenter jako niereagujące. Ponowne uruchomienie hosta może tymczasowo rozwiązać problem, jednak po kilku dniach problem pojawi się ponownie. Ten problem występuje tylko na serwerach Dell PowerEdge 14G z kontrolerem iDRAC9.

W dzienniku TSR komunikat taki jak:

2019-06-04 15:26:05 ISM0049 The iDRAC Service Module (iSM) is unable to communicate to the iDRAC because the client certificate is either unavailable or invalid.

W vmkernel.log r.

2019-06-04T02:05:56.920Z cpu61:2105520)WARNING: VisorFSObj: 1576: Cannot create file /etc/cim/dell/srvadmin/iSM/ini/tttttttttttttyZxIL9 for process sfcb-dcism because the inode table of its ramdisk (etc) is full.

W hostd.log r.

2019-06-02T13:39:59.688Z error hostd[2105490] [Originator@6876 sub=Libs opID=e4a0107a-853b-11e9-f2a3 user=dcui:vsanmgmtd] VsanUtil: Failed to lock esx.conf /etc/vmware/esx.conf.LOCK.2104629: symlink failed: No space left on device

W interfejsie użytkownika kontrolera iDRAC
Interfejs użytkownika kontrolera iDRAC wyświetlający niepowodzenie iSM

 

Cause

W kontrolerze iDRAC9 w wersji 3.30.30 wprowadzono obowiązkowe wymaganie utworzenia bezpiecznego kanału TLS z modułem iSM w wersji 3.4.0-1471 lub nowszej.

Inżynierowie firmy Dell zidentyfikowali scenariusz, w którym występuje wyciek pamięci, jeśli kontroler iDRAC9 nie wynegocjował jeszcze tego bezpiecznego połączenia TLS, jeśli iSM 3.4.0-1471 został zainstalowany lub uaktualniony przed uaktualnieniem oprogramowania wewnętrznego iDRAC. Wyciek ostatecznie powoduje również utratę liczby i-węzłów jądra z powodu zalewu tymczasowych plików INI utworzonych w /etc/dell.

Oprogramowanie VxRail zawiera wersje 4.5.400, 4.7.200 i nowsze ze zintegrowanym modułem iSM 3.4.0-1471. Do wersji 4.5.400 i 4.7.212 dodano obejście mające na celu zapobieżenie temu problemowi. Problem nie dotyczy wersji 4.7.210, ponieważ jest to wersja przeznaczona tylko do produkcji, więc nie ma żadnych aktualizacji. W związku z tym ten problem najczęściej występuje w wersjach VxRail 4.7.200 i 4.7.211.

Uwaga: Problem ten jest również możliwy, jeśli płyta główna została wymieniona z powodu awarii sprzętowej. Dotyczy to węzłów z wersją 4.7.2xx [w tym 4.7.212 i przyszłym kodem]

 

Resolution

Uruchom ponownie hosta ESXi, jeśli jest już wyświetlany jako niereagujący w vCenter.

Ponowna instalacja iSM może spowodować renegocjację bezpiecznego kanału TLS z kontrolerem iDRAC9 i ponowne rozwiązanie problemu.

Na hostach ESXi, których dotyczy problem, uruchom następujące polecenia, aby ponownie zainstalować iSM.

esxcli software vib remove -n dcism
esxcli software vib install -d <path to iSM VIB>

Jeśli w ESXi nie ma dostępnego i-węzła, można najpierw usunąć niepotrzebne pliki, ponieważ ten problem może również spowodować wyczerpanie i-węzłów.

ls -l /etc/cim/dell/srvadmin/iSM/ini/
rm -f /etc/cim/dell/srvadmin/iSM/ini/tttttt*

Jeśli płyta główna została wymieniona z powodu awarii sprzętu, powyższe kroki również mają zastosowanie.

 

Affected Products

VxRail Appliance Series

Products

VxRail Appliance Series
Article Properties
Article Number: 000060464
Article Type: Solution
Last Modified: 29 Nov 2024
Version:  4
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.