NVP-vProxy: Backup stops responding and shows a parser error: Excessive depth in document

Summary: The NetWorker VMware Protection integration is configured with the vProxy Appliance. The VMware backups are initially completed successfully and then stop responding against one of the vProxy Appliances. ...

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Symptoms

The NetWorker VMware Protection integration is configured with the vProxy Appliance. The VMware backups are initially completed successfully and then stop responding against one of the vProxy Appliances. The other vProxy Appliances can still properly process work orders in the environment. The virtual machine backup log shows that the unresponsiveness is occurring in different areas on the various virtual machines (VM).

The vbackupd-engine.log continuously shows: 

noname.xml:7: parser error : Extra content at the end of the document
a67fc16d47</uuid><contentId>d3df551ae74b3a5e1618dd2fa62962ef</contentId><parent>
 
The vmconfig command-line utility with the "reset-backup," "disable-migration," "enable-migration" options generates an XML parser error for certain virtual machines:
noname.xml:7: parser error : Excessive depth in document: 256 use XML_PARSE_HUGE option
93c9a65840</uuid><contentId>ca3f9d42bfd056ff3eb2db1f8072aa4b</contentId><parent>

Cause

A virtual machine in the Protection Group has a significant number of files in the virtual machine data store directory. For example, in one situation a virtual machine had over 2000 files in the virtual machine data store directory that were 2 years old.  

The start of the vProxy virtual machine backup workflow gathers the virtual machine configuration details and creates an XML file. The XML file includes the file names in the virtual machine data store directory. The XML information is stored in the BackupVmSessions.gob file, but the large XML parser error causes the BackupVmSessions.gob file to become unusable by the vProxy vbackupd.service.  

Resolution

The vProxy BackupVmSessions.gob must be re-created, and the vbackupd.service service is restarted.

  • Remove the virtual machine with excessive files from the Protection Group.
  • Check the status of the vbackupd service: systemctl status vbackupd.service
  • Stop the vbackupd service: systemctl stop vbackupd.service
  • Rename the gob file: mv BackupVmSessions.gob BackupVmSessions.[date]
  • Start the vbackupd service: systemctl start vbackupd.service
  • Check the status of the vbackupd service: systemctl status vbackupd.service
  • Validate progress in the vbackupd service log: tail /opt/emc/vproxy/runtime/logs/vbackupd/vbackupd-engine.log
  • If required, use the vmconfig command-line utility to clear the storage migration or backup lock flags from the affected virtual machines.

Additional Information

In some instances, the vSphere Web Console reports the affected virtual machines requires consolidation. In the vSphere Web Client, select the vCenter Server VM's tab, then use the "Manage Columns" option to show the "Needs Consolidation" column. If any of the VMware Protection Policies protected virtual machines require consolidation, the virtual machines should be consolidated using the vSphere Client.

For further details on how to consolidate a virtual machine, view Brocade knowledge base article 316575 (External Link).

 

Article Properties
Article Number: 000062010
Article Type: Solution
Last Modified: 29 Sept 2025
Version:  5
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