AppSync: Bir SUDO kullanıcısı tarafından gerçekleştirildiğinde Linux ana bilgisayarına yükleme başarısız oluyor

Summary: AppSync: Bir SUDO kullanıcısı tarafından gerçekleştirildiğinde Linux ana bilgisayarına yükleme başarısız oluyor

This article applies to This article does not apply to This article is not tied to any specific product. Not all product versions are identified in this article.

Symptoms

Bir Linux ana bilgisayarı eklerken ve Eklentiyi gönderirken aşağıdaki hata döndürülür:

AppSync Ana Bilgisayar Eklentisi ile iletişim kurulurken bir hata oluştu.
 Lütfen aracı hizmetinin çalışıp çalışmadığını kontrol edin ve gerekirse yeniden başlatın.

 

C:\program files\emc\jboss\logs yolunda bulunan AppSync server.log de aşağıdaki hatayı içerir:

SFTP üzerinden dosya alınırken hata oluştu: İzin reddedildi

Cause

Bu sorunun nedeni SUDO kullanıcısının umask işlemidir.

UMASK'ın 077 olduğu bulundu, bu da SUDO kullanıcısı tarafından oluşturulan dosyaların SUDO kullanıcısının ait olduğu grubun grup üyelerinden okunmasını kısıtladı.

SFTP düzgün çalışıyordu ancak /opt/emc/appsync dizinindeki SFTP'den oluşturulan .RSP dosyası okunamıyordu.  
 

Resolution

Eklentiyi Linux ana bilgisayarına göndermek için kullanılan SUDO kullanıcısının umask'ının, sahibinin okuma ve yazma izinlerine ve en azından grup okuma izinlerine izin veren bir umask'a sahip olduğundan emin olun.

037'lik bir umask yeterli olacaktır. 

Affected Products

AppSync

Products

AppSync
Article Properties
Article Number: 000065077
Article Type: Solution
Last Modified: 18 Sept 2025
Version:  5
Find answers to your questions from other Dell users
Support Services
Check if your device is covered by Support Services.